Sign in to follow this  
dukeav

Opus FSI Server won't start - SOLVED

Recommended Posts

It was fine a couple of days ago, but today it won't start. I am normally starting it via FSUIPC but that's not working. Starting manually also does not help, it just flashes in the Task Manager and goes away. I don't see any event in Windows event log also.

 

How do I get to work?

 

I have P3D 2.4 on Win7 64-bit with OPUS FSI 4.10.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

1. Can you show me the content of your FSISERVER.log file.

2. Do you have an Internet connection.

3. Do you have an AV program active?

 

Stephen

 

Probably best to try uninstalling and reinstalling the latest OpusFSI.msi file downloaded from our website. Sounds like something might be blocking the program from running though, your AV program or something similar.

 

Stephen

Share this post


Link to post
Share on other sites

1. Can you show me the content of your FSISERVER.log file.

2. Do you have an Internet connection.

3. Do you have an AV program active?

 

Stephen

 

Hey Stephen, thanks for the quick response.

 

FSISERVER.log:

-----------------------------------------------------

pusFSI Flight Simulator Interface
 
Log Generated Sunday, November 02, 2014, 5:43 PM Hrs 
 
Installed Folder: D:\GAMESGFW\OPUSFSI
 
No Errors Detected.
 
Installed Files:
 
OPUSFSI.DLL   Version: 4.1.0.0  , Sunday, November 02, 2014, 5:41 PM Hrs 
FSISYSTEM.DLL Version: 4.1.0.0  , Sunday, October 26, 2014, 7:48 AM Hrs 
FSISERVER.EXE Version: 4.1.0.0  , Sunday, October 26, 2014, 7:48 AM Hrs 
FSDECODER.EXE Version: 4.1.0.0  , Sunday, October 26, 2014, 7:48 AM Hrs 
----------------------------
 
The log is not getting updated, it time stamp is from yesterday.
 
Internet is on and AV is SEP. This was always true when it was running also.

Share this post


Link to post
Share on other sites

The log shows the FSISERVER.exe program is not even running.

 

Try running it manually via Windows Explorer or the Command Prompt.

 

I would advise uninstalling and installing in its own d:\OpusFSI folder as it will not locate its current install folder.

 

Stephen :-)

Share this post


Link to post
Share on other sites

As I said I ran it manually also, it does not run, just flashes for a second in the Task manager and goes away.

 

Now I re-installed in D:\OP..., and I get the error dialog that Simulator's installation folder is undefined. The manual tells me to change it on Configuration Dialog. Where is this dialog? I can't find it and is there a way to set the sim location in a settings file?

 

Edit: I see where the dialog should be launched from. Now its chicken and egg story...

Share this post


Link to post
Share on other sites

It's not an error or chicken and egg, just close the warning dialog and wait for the FSISERVER to initialise, open the Configure dialog and set the options. You could also just copy your dat, cam and other files into the new d:\OpusFSI folder to preserve your previous configuration and data.

 

If it just flashes on the screen then it is clearly not running and something is preventing the program running. The software is not running at all.

 

Stephen :-)

 

Can you check to see if any security software is blocking the program from running.

 

Have you downloaded the OpusFSI.msi file again and reinstalled?

 

Stephen

Share this post


Link to post
Share on other sites

It's not an error or chicken and egg, just close the warning dialog and wait for the FSISERVER to initialise, open the Configure dialog and set the options. You could also just copy your dat, cam and other files into the new d:\OpusFSI folder to preserve your previous configuration and data.

 

If it just flashes on the screen then it is clearly not running and something is preventing the program running. The software is not running at all.

 

Stephen :-)

 

Well, it is. If say ok to the error dialog and wait, nothing happens. I have checked in Task Manager, the server just goes away after clicking ok.

 

Now I copied the FSISERVERCFG.DAT from the old install, and its first problem. No error dialog, it just quits in a flash.

Share this post


Link to post
Share on other sites

Just the same problem, the program is not running, it is being aborted. That's why no form appeared the program is being aborted. Can you email me your licence number and I will check that no problem exists at the server.

 

Have you downloaded and reinstalled as mentioned above.

 

Have you stopped any security software.

 

Stephen

 

Just download the msi and reinstall just in case something's got corrupted.

 

Stephen

 

Have you got more than one copy installed on your system or listed in the Windows program list.

Share this post


Link to post
Share on other sites

Just the same problem, the program is not running, it is being aborted. That's why no form appeared the program is being aborted. Can you email me your licence number and I will check that no problem exists at the server.

 

Have you downloaded and reinstalled as mentioned above.

 

Have you stopped any security software.

 

Stephen

 

Just download the msi and reinstall just in case something's got corrupted.

 

Stephen

 

Have you got more than one copy installed on your system or listed in the Windows program list.

 

I disabled SEP, but you know parts of it can't be disabled. There was only one installed.

 

I just PM'd you my licence.

 

I am trying to re-install from another backup of installer now.

 

Edit: Re-install did not help, same result.

 

Edit2: BTW, the client launches fine, even though I do not need it.

Share this post


Link to post
Share on other sites

 

Make sure you only have a single copy of the software installed. Download the OpusFSI.msi Upgrade file a new from our website, uninstall and then install using the new msi file. It could be you have a mismatched set of library files or something similar.

 

Stephen

 

Please uninstall and reinstall using a new OpusFSI.msi, not a backup one.

 

Stephen

Share this post


Link to post
Share on other sites

Make sure you only have a single copy of the software installed. Download the OpusFSI.msi Upgrade file a new from our website, uninstall and then install using the new msi file. It could be you have a mismatched set of library files or something similar.

 

Stephen

 

Please uninstall and reinstall using a new OpusFSI.msi, not a backup one.

 

Stephen

 

Ok.

 

I un-installed the old one.

 

Verified that there is no Opus in Uninstall Programs.

 

Downloaded new from here - http://www.opussoftware.co.uk/opusfsi/OpusFSI.msi and installed again.

 

Disable SEP.

 

Ran it, same error dialog and it closes after that

Copied the dat file, now it just flashes in Task manager and goes away. So no change.

Share this post


Link to post
Share on other sites

Can you confirm that you do not have any other folders named OpusFSI on your system. You should only have one, the d:\OpusFSI folder and your licence files in c:\Opus Software.

 

Stephen

 

You could try updating Windows or your dot net framework software just in case you have problems with dot net.

 

Without running the sim or anything else, can you run the FSICLIENT program.

Share this post


Link to post
Share on other sites

Can you confirm that you do not have any other folders named OpusFSI on your system. You should only have one, the d:\OpusFSI folder and your licence files in c:\Opus Software.

 

Stephen

 

Yes, that's how it is. I renamed even the original folder where it was working.

 

A few Windows Updates came in today for me. Maybe that's the problem. Do you have a test setup of Win 64-bit with all updates?

Share this post


Link to post
Share on other sites

We are on holiday. The only other person reporting something similar cured it by rebooting the computer.

 

Stephen

 

You could also try reinstalling SimConnect using our supplied msi file, that's what the other guy did then rebooted.

 

Stephen

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this