Sign in to follow this  
B777_AVSIM_01

FSX crashing issue

Recommended Posts

Hello guys.

 

A couple of months ago, I bought a new PC. Here are some system properties:

- Windows 7 Home Premium 64-Bit

- Intel Core i7 4790K, OC 4.5gHz

- nVidia GeForce GTX760 2GB

- 8GB RAM

- 256 Samsung SSD (FSX installed on there)

 

Of course I have installes many addons, and I wanted to fly the PMDG 737 from LGIR to LOWW yesterday. When I was established on the ILS for RWY34 in LOWW, my FSX crashed. Okay - i though - this can happen, let's try again tomorrow. Now I also wanted to do the same flight, and my FSX crashed one minute before planned Off-Block time with the following text:

 

Problemsignatur:
  Problemereignisname: BEX
  Anwendungsname: fsx.exe
  Anwendungsversion: 10.0.61637.0
  Anwendungszeitstempel: 46fadb14
  Fehlermodulname: StackHash_e16f
  Fehlermodulversion: 0.0.0.0
  Fehlermodulzeitstempel: 00000000
  Ausnahmeoffset: 7515cb49
  Ausnahmecode: c0000005
  Ausnahmedaten: 00000008
  Betriebsystemversion: 6.1.7601.2.1.0.768.3
  Gebietsschema-ID: 3079
  Zusatzinformation 1: e16f
  Zusatzinformation 2: e16f26ed920b77e80b57d6228a772083
  Zusatzinformation 3: c050
  Zusatzinformation 4: c050ce9318e2fdcce8b19a1e937d6310
 
Lesen Sie unsere Datenschutzbestimmungen online:
 
Wenn die Onlinedatenschutzbestimmungen nicht verfügbar sind, lesen Sie unsere Datenschutzbestimmungen offline:
  C:\windows\system32\de-DE\erofflps.txt
 
I am always running FSX in the Admin mode. Does he run out of RAM? Is there maybe a fix for this? Anybody got the same problems?
 
Best regards from Austria, and thank you in advance.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

This is an automatic message.

 

This topic has been moved from "MS FSX Forum" to "Crash To Desktop (CTD) Forum". This move has been done for a number of possible reasons.

  • The most likely reason is that the post was off topic.
  • The topic could also have contained images or a video that were not appropriate to the original forum it was posted in.
  • The images might not have been "illustrative" or "explanatory" in nature.
  • The topic could have been moved because we deemed it to be more appropriately placed elsewhere.
Please ensure that your posts are "on topic" and contain illustrative images or videos as appropriate. Do not post videos or images just for entertainment purposes anywhere but in the screen shot or video forums. See our image posting rules here.

 

Members who continue to post off topic posts can be denied entry to specific forums in order to reduce and remove the practice. Your cooperation is appreciated.

Share this post


Link to post
Share on other sites

I am always running FSX in the Admin mode. Does he run out of RAM? Is there maybe a fix for this? Anybody got the same problems?

You did not run out of virtual address space (VAS) or RAM as you did not have an out of memory event. You had a BEX/StackHash.....

 

BEX – Buffer Exception Overrun or Buffer Overrun. More information about BEX crashes can be found at the following link - http://en.wikipedia.org/wiki/Buffer_overflow.

 

StackHash – There is no module on your computer system named StackHash so no need to look for it. If the StackHash is shown as the faulting module, it will have four characters next to it like StackHash_E16f. That represents the memory address of where the fault occurred. Do not try to look for it. You will not find it. There is no known solution (except one) to BEX/StackHash errors other than reinstalling Windows and FSX but some have accidently fixed their problem by lowering fsx/display driver settings, rebuilding the FSX.cfg, changing voltages/overclocking settings in the BIOS, disabling all scenery add-ons in the Scenery Library, and/or shutting down FSX only in Windowed Mode and starting up in Windowed Mode but never in Full Screen. One known solution is disabling MyTrafficX 5.4c in your Scenery Library (if installed). An AI schedule might be causing this crash as the schedule may be looking for a flight and it cannot be found. There are also AFCAD’s that come with MTX and some of those may contain objects. See developer's website.  If disabling MTX in the Scenery Library works, then you should reinstall the product and use the default schedules. Disabling DEP has worked for some but it is not the recommended solution. FSX will not allow you to disable DEP. It can only be done by a freeware program that you can download from the Internet (search Google). It has not worked for many but I mention it as it has worked for some.

 

If you have the uiautomationcore.dll "fix" in your main fsx folder, move it to another temporary directory. 

 

Here's another suggestion taken from an upcoming revision to the AVSIM CTD Guide:

 

Return FSX/P3D to the default configuration. This is done by rebuilding your FSX/P3D configuration; disabling add-on scenery; and disabling modules in your dll.xml or exe.xml as follows –

• Rebuild the FSX/P3D Configurations – Many CTD’s can be fixed by renaming your FSX or P3D configuration to FSX or P3D.orig (or you can move the file to a temporary folder), restarting FSX/P3D and letting the configuration rebuild. The FSX/P3D configurations are hidden (C:\User\(yourusername)\AppData\ Roaming\ Microsoft or Lockheed Martin\FSX or P3D. It has been said that rebuilding your configuration is about the same as uninstalling/reinstalling FSX or P3D, as appropriate, as it removes tweaks or other parameters that you have added and may be causing more harm than good.

• Disable Add-on Scenery – Disable all your add-on scenery in the Scenery Library (Hidden - C:\Program Data\Microsoft or LockHeed Martin\FSX or P3D), then run the program and see if this fixes the problem. If it does, then the problem is probably associated with one or more of your add-on sceneries. To find the offending scenery, enable your add-ons 3-4 at a time until the CTD returns.

• Disable modules in dll.xml and exe.dll– Sometimes a module you have installed is corrupted or is somehow duplicated in the dll.xml. You can check to see if any modules are the cause of your crashes by disabling all modules (except the first one). Change the parameter False in the line <Disabled>False</Disabled> to True or simply move the dll.xml and exe.xml to a temporary folder and restart your program. If the problem is fixed, move the file back to the proper P3D/FSX folder and enable each module one by one until the culprit is found.

 

Hope this helps.

 

Best regards,

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this