Sign in to follow this  
fsxnate

EZ DOK issues Prepar3d 2.4

Recommended Posts

Hey folks,

 

I have spent quite a bit of time browsing the EZ Dok compatibility threads and I just can't seem to get mine to work.  I have done the following:

 

1. Installed EZ Dok and updated it to 1.17 with Migrator tool from flight sim estonia

2. Downloaded EZ Dok Prepare3d.exe and updated/made sure XML is in the Prepar3d EXE and it is set to Disabled - False - Disabled

3. I ran the configurator and it did pick up all my aircraft in Prepar3d

4. I started Prepar3d and EZ Dok comes up but stays greyed out (the interface doesn't have anything green, as if it just isn't connected).  I then quit out of EZ Dok and tried loading it manually to the same result.  Also when I hit addons I don't see the Show Studio option either

 

any ideas?

 

thanks

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Hi nathan

If you want you can start p3d and then run the ezdok.exe from inside where it is installed.

if it starts that way then you know it is ezdok not finding your p3d install.

maybe a good idea to post you EXE file so people can compare it .

 

 steve

Share this post


Link to post

I started P3D and then ran the ezdok_prepar3d.exe form inside where it is installed and it started but to the what I describe as a disconnected look, no aircraft found.  So it sounds like it's not finding my P3D install as you suggested, what's interesting is it is starting up when I launch P3D. Here is my XML file:

 

 

 

 

 

 

 

<?xml version="1.0" encoding="WINDOWS-1252"?>

 

<SimBase.Document version="1,0" Type="Launch">

<Descr>Launch</Descr><Filename>exe.xml</Filename><Disabled>False</Disabled><Launch.ManualLoad>False</Launch.ManualLoad><Launch.Addon><Name>Couatl</Name><Disabled>False</Disabled><ManualLoad>False</ManualLoad><Path>fsdreamteam\couatl\couatl.exe</Path><CommandLine>--mode=prepar3dv2</CommandLine></Launch.Addon><Launch.Addon><Name>Saitek Panel(s) Plugin for FSX</Name><Disabled>False</Disabled><Path>C:\Program Files (x86)\Saitek\Pro Flight Panels\SaiPanels.exe</Path><CommandLine>-run</CommandLine></Launch.Addon><Launch.Addon><Disabled>False</Disabled><ManualLoad>False</ManualLoad><Name>UT2</Name><Path>C:\Program Files (x86)\Lockheed Martin\Prepar3D v2\\Flight One Software\Ultimate Traffic 2\UT2Services.exe</Path><NewConsole>True</NewConsole></Launch.Addon><Launch.Addon><Name>EZdok camera addon</Name><Disabled>false</Disabled><Path>C:\Program Files (x86)\EZCA\EZCA_P3D.exe</Path></Launch.Addon>

</SimBase.Document>

Share this post


Link to post

when I click on a view I get the access violation error as well....it looks like I'll have to load FSX back onto the computer, but I'm surprised considering I've had it working before

Share this post


Link to post

Hi nathan .

this my section of the EXE.dll for ezdok

 

<Launch.Addon>
    <Name>EZdok camera addon</Name>
    <Disabled>false</Disabled>
    <Path>C:\Program Files (x86)\EZCA\EZCA.exe</Path>
  </Launch.Addon>

 

your path is wrong i think

here is yours

<Path>C:\Program Files (x86)\EZCA\EZCA_P3D.exe</Path></Launch.Addon>

edit the file and change it to what i have.

also in your Ezdok Directory you should have the ezdok.exe .that is compatible with P3D .but you do not rename it just overwrite the original ezdok.exe with the new one.

let me know how you get on.hopefully when you take _P3D out of the path it should solve the problem.

 

  steve

Share this post


Link to post

Thank you for the continued support!  I did two changes:

 

1. I modified my exe so it had the XML tag like yours with EZCA instead

2. When I installed this first I renamed my EZCA.exe to EZCA.old, so I renamed it back to EZCA and overrode what was in there.  I then unzipped the compatible P3D EZCA and put it in there and chose to override again. 

 

Unfortunately this did not resolve my issue.  EZ DOK launches with P3D but no aircraft are selected and it seems greyed out.

 

as before thank you for your continued help!

Share this post


Link to post

Hi Nathan

it took me a while also and suddenly it started working.i swapped all of my EXE.DLL file with someone elses in another post.

backup your one and try mine .this came from someone who also had problems starting EZDOK.test it and see if it launches.

 

  steve

 

<?xml version="1.0" encoding="windows-1252"?>
<SimBase.Document Type="Launch" version="1,0">
  <Descr>Launch</Descr>
  <Filename>exe.xml</Filename>
  <Disabled>False</Disabled>
  <Launch.ManualLoad>False</Launch.ManualLoad>
  <Launch.Addon>
    <Name>EZdok camera addon</Name>
    <Disabled>false</Disabled>
    <Path>C:\Program Files (x86)\EZCA\EZCA.exe</Path>
  </Launch.Addon>
    <Launch.Addon>
        <Name>Saitek Panel(s) Plugin for FSX</Name>
        <Disabled>False</Disabled>
        <Path>C:\Program Files (x86)\Saitek\Pro Flight Panels\SaiPanels.exe</Path>
        <CommandLine>-run</CommandLine>
    </Launch.Addon>
</SimBase.Document> 

Share this post


Link to post

So what's interesting is when I swapped it, I did notice the World Camera was present when I right clicked in Prepar3d.  I then swapped mine back and it is there as well, so it makes me think it's partially in there.  I went back to my Prepar3d folder in App data and under the Cameras section, Camera 202 is a world ezdok camera.  So it's partially working? its just the studio is greyed out, now I did run configure and it did pick up all my aircraft.  I go into EZCA folder in Program Files X86 and click on DB then Virtual Cockpit, there isn't much in there but in the EZCA folder in App data there are a bunch of config files there.  Strange for sure!

 

thanks


Here is a visual of what I'm seeing, notice how everything is greyed out and no aircraft selected, also when you click add ons there is no entry in there for EZ DOK

EZDOK24_zpsb0d3d8a8.jpg

Share this post


Link to post

Hi nathan

try this.just remembered i needed to do this..

In your P3d Main Folder you will find a folder named redist /interface.These folder contains 5 subfolders.Each of these subfolders contains  a folder named retail / lic.

In every of these lib folders is a simconnect.Msi file.Update these by double clicking on them.you don't have to do the JPN and RUS ones

 

FSX RTM/RETAIL/LIB/ double click the MSI file and it should update.

 

same for FSX SP1 and FSX SP2 folders

 

 

 

 

  steve

Share this post


Link to post

YOU ARE AWESOME, THAT WAS THE EXACT ISSUE!  thank you thank you, this is now *resolved* if anyone reads this and has a similiar issue

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this