Sign in to follow this  
chuckson89

FS Passengers FSUIPC4.dll Crash

Recommended Posts

Hi guys,

I just bought FSPassengers for FSX. Im using it with the PMDG 777, when I load the passengers in my plane, the FSX Crashes, the log everytime shows FSUIPC4.dll is reason here is the Log in German:

 

Name der fehlerhaften Anwendung: fsx.exe, Version: 10.0.61472.0, Zeitstempel: 0x475e17d3
Name des fehlerhaften Moduls: FSUIPC4.dll_unloaded, Version: 4.9.2.9, Zeitstempel: 0x52fb695f
Ausnahmecode: 0xc000041d
Fehleroffset: 0x0008319c
ID des fehlerhaften Prozesses: 0x180c
Startzeit der fehlerhaften Anwendung: 0x01d016c2fcae9637
Pfad der fehlerhaften Anwendung: C:\Program Files (x86)\Microsoft Games\Microsoft Flight Simulator X\fsx.exe
Pfad des fehlerhaften Moduls: FSUIPC4.dll
Berichtskennung: 7fa7011a-82b8-11e4-bf20-902b34aaaf93
Vollständiger Name des fehlerhaften Pakets:
Anwendungs-ID, die relativ zum fehlerhaften Paket ist:

 

I also tried readding the UIAutomationcore, nothing worked, also reinstalling of all programs including FSUIPC4 did not work out. Im out of ideas now, so im writing you, please help me...

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Upgrade FSUIPC4 to the latest version. Yours is quite old. FS Passengers does not need the FSUIPC utility and, on their website, they clearly state to be "very careful with installing addon utilities". I do not know what that actually means but fsuipc is one of the few utilities I know about. I suspect FS Co-Pilot and FSInn could be a problem with FSP too as they are utilities. However, the crash was not caused by FSP but by the utility, FSUIPC. I don't know who installed the utility. Maybe it was done by FSP? I don't think there is any program that installs fsuipc with their software program. On their website they do not indicate FSUIPC is required. The PMDG 777 does not need the utility. You can try to disable it as suggested in the AVSIM CTD Guide and see if that fixes the problem if an update does not work. FSP is a very old program that is no longer supported; however, FSX/Acceleration are in the same very old boat as they are very old and no longer supported too.

 

The uiautomationcore.dll, version 16386 or 18000, fixes only one type of crash, a fsx menu crash. You have to click on your menu at least 19 times to make it crash and I have personally found that impossible. Only causes crashes on certain systems. Most users of FSX will not need it, especially if you have a modern computer system (which you must have as you own the pMDg777).

 

More information can be found in the AVSIM CTD Guide.

 

Best regards,

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this