Sign in to follow this  
calibra2001

Lights Problem on standard 737-800

Recommended Posts

Hi

 

I have just purchased my copy of fsuipc and downloaded Linda 2.5.7

I have some slight problems regarding lights in the 737. If i turn on the panel lights using a switch, when i turn on taxi lights, strobe, Anti-collision (Beacon), they all tend to switch off the panel lights. But turning on landing lights and/or (66376) Logo light, the panel light will remain until one of the other switches is switched.

 

Please note i am very new to all this, so any help would be much appreciated.

 

Also on the console i notice after making a new aircraft module, the next time i start the computer and startup FSX if i want/need to make any adjustments the console always says [E] *** LUA Error: cannot open linda-cfg/aircrafts/Standard 737/config-mcp.lua: No such file or directory. Regardless of this all programing i did all is there (switch assignments)

 

Thanks

 

Phil

Share this post


Link to post
Share on other sites

Hi Calibra2001

 

Welcome to LINDA.  There is no specific module for the Standard 737-800 and each aircraft module is specific to a particular type of aircraft addon.  The one supplied with LINDA 2.5.7 is for the PMDG 737NGX.

 

There is a common fault with some modules where there is an adverse interaction between certain light switch functions especially the Panel Light. I have only fixed this so far in the Aerosoft Airbus 4.3 module.

 

You will see the error message 'cannot open ... config-mcp*.lua' whenever you first select a new aircraft for which the file has not been created. As soon as you click on MCP Combo button one will be created automatically for you.

 

I hope that helps.

Edited by ScotFlieger

Share this post


Link to post
Share on other sites

Hi Scot

 

This error message baffles me, do i need to worry about it as I have not got MCP Combo enabled as I haven't even got such a device, My switch panels are home made and using a usb module interface. I have been selecting fsx default commands, as its a default plane. Everything seems fine on the Cessna regarding lights and panel lights etc.

 

Thanks

 

Phil

Share this post


Link to post
Share on other sites

Hi Phil

 

Make sure that the MCP is disabled on the MCP Settings page to prevent the error.

 

I think you will find that there is an adverse interaction between the Panel Light and others even on the FSX Default. It is most noticeable at night when you have the Landing Lights on and then switch on the Panel Light.  I think I read somewhere that it is a 'feature' of FSX.

Share this post


Link to post
Share on other sites

Hi Scot

 

MCP is disabled but i still get the error.

 

Maybe i will have a good look using FSUIPC and the console too and see if i can get around the lighting problem. Is it wise to mix controls between FSUIPC and LINDA, some controls i have noticed work better in the other App.

 

Thanks for your help

Phil

Share this post


Link to post
Share on other sites

Hi Phil

 

You need to be careful mixing FSUIPC and LINDA assignment as they will conflict with each other giving weird results. The same applies to FSX assignments. My preference is:

 

  • Remove all button and axis assignments from FSX except POV.
  • Use FSUIPC for axes (LINDA can't handle them) and rapid repeating buttons (ie. thrust reverse).
  • Use LINDA for everything else.

If you are very desperate to solve the lighting conflict download the Aerosoft Airbus 4.3 module and look at the code under OVHD Ext and Int Lights sections. Basically, I had to remember the state of certain lights, toggle panel lights and then reinstate the affected ones. Good luck.

 

If you get something working let me know.

Share this post


Link to post
Share on other sites

Hi Scot

 

Thanks for the info, I'm not sure I'm advanced enough to be looking at codes. I have noticed that I cannot manage to make some toggle commands work in harmony with the switches (no precise on/off command) for example parking brake, I have tried parameter 0 and 1, but to no avail. But on this one i have found an offset command for FSUIPC, which with the parameter will actually synchronize with the switch. I'm sure there is a way, but i haven't figured it out yet. Then there is some in LINDA which have the on/off commands which aren't available in FSUIPC which is why I am thinking about mixing, I guess as long as the switch doesn't have any assignment in LINDA the using FSUIPC will work ok for that switch and vice versa?

Hopefully I will master this slowly,

 

Thanks Phil

Share this post


Link to post
Share on other sites

Hi Phil

Welcome to the fun of programming!  I have been doing it for over 30 years and I still scratch my head at times. If the separate on and off functions work but the toggle does not then it normally means that you are suffering from keyboard bounce (ie. the button is being seen twice or more times in quick succession). The way to handle that is to add or increase the delay after the on/off instruction with the function ipc.sleep(x). Where x = delay in milliseconds, 20-50ms will do.

Share this post


Link to post
Share on other sites

Hi

 

I'm not sure its keyboard bounce, its more there is not a definate on/off function.

I will try to explain: if flick the switch for parking brake on (it goes to ON which is good), switch off (parking brake OFF), but if i use the switch to Parking brake on, then click the mouse on parking brake it goes off, but if i then switch Parking Brake off with the switch (it then goes to ON) even thought the switch is in the OFF position. which I call going out of sync.

 

Thia isnt really a problem, as i wont click on them using the mouse, but when a new flight is started, some of the controls are out of sync depending where the switches are positioned compared to how the plane appears in FSX.

 

I hope you can understand what i mean

 

Thanks

Phil

Share this post


Link to post
Share on other sites

Hi Phil

 

You need to be careful with the parking brake and FSX only provides a toggle function. So using the mouse to put it 'out of sync' will cause you problems. Toggle controls can only be toggled unless your code checks the state first and decide whether to toggle or not. As far as initial conditions are concerned, you need to think of an initialisation function (best placed in a function called InitVars in your module) that checks all the states/switch positions on start up so that your module has a fixed starting point.

Share this post


Link to post
Share on other sites

Hi Scot

 

I'm not saying I do or would use the mouse, to get it out of sync, it just sometimes happens with other toggle functions on startup, or when i enter a previous saved flight, the switches can be out of sync, maybe i will see about setting a cold and dark setup on every-aircraft so i know all switches off and parking brake on. Not sure how to do that yet but I'm sure there will be a way.Hopefully in the next few days i will be able to sit down and study whats happening, and then master ways of making everything happen as i want it to.

 

Thanks for your help

 

Phil

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this