Sign in to follow this  
Claude Troncy

Problem with camera zoom

Recommended Posts

Bonjour,

 

I have 2 identical cameras. one with a zoom of 0.64 and a cloned one with a zoom equal to 1.00.

In the camera management dialog when switching from one camera to another everything is OK, but when I use the buttons to do the same thing, the zoom is not consistent, and at the end the zoom which normally should be 1.00 is equal to 0.30.

 

Any idea of what is wrong

Best regards

Claude 

 

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi Claude,

 

The zoom can only be adjusted in coarse and fine steps and cannot be set to a specific value. You should edit your camera views and if possible stuck to the default zoom and use eye point adjustments to achieve your desired view. If the zoom change is considered essential then try to always use the absolute minimum number of minor steps or fine adjustment steps as these alter the zoom by a different amount depending on its current scaling. So much best to stick with all default zooms. If not then try and only make coarse adjustments. If not then use the absolute minimum number of fine steps.

 

Also make sure you are using the latest beta or release version, especially if needing GRIB forecast data as there have been changes at NOAA, the query servers are currently off line but the latest OpusFSX and OpusFSI versions take account of this.

 

If using P3D and OpusFSI then make sure you enable the OpusPDK Interface as P3D v2.4 does not handle 6DOF SimConnect requests very well.

 

Stephen :-)

 

I should have mentioned. Of course do not manually adjust the zoom using the = and + keys (unless yo manually reverse the steps). The software cannot determine any zoom or eye point changes to make inside the sim.

 

Much better with P3D and the OpusPDK Interface.

 

Stephen :-)

Share this post


Link to post
Share on other sites

Hi Stephen,

 

Thanks for your quick answer.

I would like to have a different zoom on final approach which cannot be done just by modifying eye point.

 

I only use coarse zoom adjustment when defining my camera view.

 

I am a bit confused because I have created different cameras views with different zoom (0.7 0.5 and 0.64) some times ago. And when I switch between them, I have no problem.

But yesterday I wanted to create a new one (the 0.64 cloned with zoom 1.0), and the behavior is different.

 

 

I use FSX, OPUSFSI 4.44.1

 

Best regards

Claude 

Share this post


Link to post
Share on other sites

Hi Claude,

 

You must have some fine zoom steps in there as 0.64 cannot be achieved otherwise. I needed 30 fine steps. If the are any fine steps the zoom level will be indicated as either 0.60+ or 0.60-. I would advise double checking all your views. Edit the zoom setting, set default then use the coarse zoom to adjust as required. I will see about checking the fine steps in the future and force a full zoom reset whenever any fine stepping has been specified in the previous or new camera view intending to transition to.

 

Best regards

Stephen :-)


I would also advise you to upgrade or wait for the 4.45 Release version to be posted next week.

 

Stephen :-)

Share this post


Link to post
Share on other sites

Hi Stephen,

 

Do not ask me what I have done, but it is working now. May be I do not understand how you move from one zoom to another.

It is not still clear to me. I thought that you just pass to the sim a order like "Set zoom to", but obviously it is not the way it works.

 

I think I was not on the right zoom when I press the button, may be the effect was like if I had adjust the zoom using the = and + keys.

Thanks

Best regards

Claude

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this