Sign in to follow this  
ScotFlieger

NEW - LINDA 2.6.3 Released

Recommended Posts

The latest version of LINDA 2.6.3 has completed beta testing and is formal released.

 

Due to my other commitments, there will be a pause in development, although I will address any issues raised by users.  Many thank for the comments and feedback of those who helped with the beta testing.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Has the issue with the memory leak been fixed? I had to remove the lua file and and stop it from auto launching all together.

Share this post


Link to post
Share on other sites

when will it be out? :D

 

 

It has been released here under Downloads. This announcement thread is simply to draw your attention to that fact. It just takes a little looking.

 

 

Has the issue with the memory leak been fixed? I had to remove the lua file and and stop it from auto launching all together.

 

 

What memory leak would that be? No such problems have been reported during beta testing.

Share this post


Link to post
Share on other sites
- <System>
  <Provider Name="Application Error" /> 
  <EventID Qualifiers="0">1000</EventID> 
  <Level>2</Level> 
  <Task>100</Task> 
  <Keywords>0x80000000000000</Keywords> 
  <TimeCreated SystemTime="2015-03-04T18:46:03.000000000Z" /> 
  <EventRecordID>8368</EventRecordID> 
  <Channel>Application</Channel> 
  <Computer>MainRig</Computer> 
  <Security /> 
  </System>
- <EventData>
  <Data>Prepar3D.exe</Data> 
  <Data>2.5.12944.0</Data> 
  <Data>54ee1a39</Data> 
  <Data>ntdll.dll</Data> 
  <Data>6.3.9600.17630</Data> 
  <Data>54b0d74f</Data> 
  <Data>c0000005</Data> 
  <Data>0001e193</Data> 
  <Data>2b04</Data> 
  <Data>01d056ab3d0ba638</Data> 
  <Data>H:\Prepar3d\Prepar3D.exe</Data> 
  <Data>C:\Windows\SYSTEM32\ntdll.dll</Data> 
  <Data>b4d786d8-c29e-11e4-828b-e03f4980756e</Data> 
  <Data /> 
  <Data /> 
  </EventData>
  </Event>
 
 
FSX and P3D would crash on startup with ntdll.dll.  I removed the lua file from FSUIPC and renamed it to linda.lua.old and no crash. Same result with every beta. It also hangs on start and doesn't register any of the inputs from my saitek panel.  I have the switch, multi and radio panels. 

I don't have the crash reports anymore but it was a BEX error. 

Share this post


Link to post
Share on other sites

Try 2.6.0.  Saitek panels have been added.

 

I wiped out all of the linda sys config files and copied the new files again. No crash this time. Thanks for your work.  Now to figure out how to tune the panels with it.  PMDG's 777 is one stubborn SOB.

Share this post


Link to post
Share on other sites

it crashes everytime :/

 

 

That is not very helpful and does not enable me even to start helping you. Go to the Read me posts under Support and file a better and full description.  Make sure you have read the installation notes first.

Share this post


Link to post
Share on other sites

Please familiarise yourself with the LINDA forums. You will find it here and please post under support.

Share this post


Link to post
Share on other sites

LINDA 2.6.2 has been issued to fix the slow start reported by some users with multiple non-standard HID devices which have no product name.  Go to the DOWNLOAD sub-forum.

Share this post


Link to post
Share on other sites

All Versions after 2.5.7 (including 2.6.2) are still causing FSX to crash faulting ntdll.dll. Is there perhaps any way that we could get a version of 2.5.7 with the panel position saving put back in it?

 

Thanks,

Bao

Share this post


Link to post
Share on other sites

Hi Bao

 

I do not know what is causing FSX to crash. I have not seen it but I would suggest you try 2.6.2 first.

 

I do not have time to go back and rework 2.5.7 to add new features at present.  LINDA 2.5.7 is available at the bottom of the top post in LINDA Download sub-forum.  That is a thought!  It could be the panel position code that had been "disabled" when I took over the code that is causing the crash to desktop.

Share this post


Link to post
Share on other sites

LINDA 2.6.3 released with permanent fix for crash on start up for non-MCP users.

Share this post


Link to post
Share on other sites

Is it me or does Linda not switch automatically to the selected aircraft?  I thought it use to.  Now I'm having to tell Linda which aircraft I'm using

Share this post


Link to post
Share on other sites

Hi burns

 

The current aircraft should be displayed at the top of the page but it is only operative if the dropdown box is outlined in orange.  You need to click on the FSXSync button to synchronise LINDA with the aircraft you are flying.  It is important that the name in the dropdown box matches the aircraft description and the aircraft module folders names (ie. Aerosoft Airbus).  There is a particular problem with the A2A A172 clashing with the default Microsoft C172.

Share this post


Link to post
Share on other sites

It is immediately to the right of the aircraft dropdown at top of page.

Share this post


Link to post
Share on other sites

Okay, I found the button but its 'greyed out'...dim...not selectable when using FSX-SE.

 

I can choose it when running regular CD version of FSX.

 

Guess its a bug?

Share this post


Link to post
Share on other sites

Interesting. I have been using LINDA sync'ed with FSX-SE for some time now.  Compare which aircraft (objects) you have and the \modules\linda and \modules\linda-cfg between FSX and FSX-SE.  If you do not have an aircraft module matching the first part of the aircraft name it can cause problems. For example, the "Aerosoft Airbus" would include Aerosoft Airbus A319, A320, etc but "Aerosoft Airbus A320" would only reference the A320 version.  This can be edited by click Edit to the left of the aircraft name.

Share this post


Link to post
Share on other sites

I can manually select the aircraft, which I assume implies LINDA knows about it.  Its just the sync button that isn't enabled.

 

The directories look identical.  27 items in the linda/aircraft folder and linda-cfg/aircraft folder for both FSX and FSX-SE

 

Once I select an aircraft in FSX-SE, FSX SYNC becomes selectable and LINDA does change when I change aircraft.  But not until I select the first aircraft.

Share this post


Link to post
Share on other sites

That is how it should work. The FSX SYNC can only sync to the currently selected aircraft in the simulator because it requires FSUIPC to be running to identify the airframe type.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this