Sign in to follow this  
thetford569

Brakes come on in air

Recommended Posts

I am at a loss....I originally thought this problem was due to the age and some possible internal damage to my CH pedals but I just purchased a set of saitek pedals and I have the same issue. After takeoff at approx 3-4,000 ft I get the brakes message appearing on screen in the sim. Upon landing the brakes are applied and quickly bring me to a stop without using any thrust reversers or speed brakes. Obviously this is unrealistic and really kills it for me after a flight. As soon as the aircraft comes to a complete stop the brakes shut off and everything works normally. This doesn't seem to be a calibration issue and no matter what I do as far as pressing the toe brakes in flight or engaging the parking brake in flight I can't get the brakes message to go off the screen. The brakes are working normally on the ground so this doesn't seem like a calibration problem like ive seen others have. Ideas?

 

Brandon

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Your axis is reversed. Don't know what you use to set up your axis for each pedal, but you can reverse the assignment in the set up screen in FSX, or in FSUIPC if that's what you're using.

Share this post


Link to post

After some further investigation this appears to be happening only with the Eaglesoft Citation X....it's not happening with default aircraft.  Soon after takeoff right after around 4-5,000 ft. the brakes come on.

 

Brandon

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this