Sign in to follow this  
MarkSC

How to Get CH Eclipse Working in 2.5

Recommended Posts

Has anyone gotten CH Eclipse yoke to work in 2.5 with Win 8.1?  I never had an issue before (was using SPAD).  I've tried both SPAD and the official Saitek P3D drivers with no luck.  P3D just does not recognize the controller (shows it as a mouse and is wildly out of calibration).  If I unplug the controller and replug (a trick that worked in previous versions of P3D if there was a disconnect) P3D will lose the controller for good. Basically, I cannot use the yoke at all.

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

If you are really trying to use Saitek drivers on a CH product, this may be the problem!

 

I have the CH Eclipse on my Win7 64 P3DV2.5 and it works fine. I use the CH Control Manager to calibrate and then assign functions via the default P3D Controls function. No other drivers or program needed.

 

Hope this helps.

 

Lyn

Share this post


Link to post

Duh, yes I forgot that. I have Saitek multi panel, so i'm used to thinking of the yoke as Saitek too.  I've never had to use CH Control Manager in the past, but I'll give it a try. Thanks.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this