Jump to content


This topic is now archived and is closed to further replies.


FS9 stays strong! But is the DF Dakota lost?

Recommended Posts

Hello everybody!


Thanks god (and AVSIM) for this forum! I'm very happy to see so many people still loving good old FS9. And I know people here (and on a very few other great sites) are very knowledgeable about this sim.

Personally I enjoy FS9 even more than 10 years ago. Underway my scenery.cfg grew up to more than 1.500 entries. Hundreds of aircrafts were tested. Wonderful freeware and expensive payware came up.  Sometimes ( or should I say often?) it was rather fiddly to make it all fit together...You know the highs and lows of our hobby. In the end it mostly was going well.


But now I'm rather frustrated. You know, my everytime GA favorites (besides the outstanding works from RealAir and the later Carenado) were the planes from Dreamfleet. Especially the A36 and the B58 - again and again I come back to them. They're marvellous.

After porting over to Win7/64bit I spent much time to make them work again (and I gave even more money away as  thereto one has to buy nearly all current products from RealityXP, who - with due to respect - should be praised for their stuff, but blamed for their exorbitant prices). Bert Pieke - he's a fine chap - helped me in particular.


So recently I decided even to buy the Dreamfleet Dakota, for all that I knew that DF is as still as a grave. I ignored the warning that the Dakota was developed for Windows XP/32bit, I simply trusted in a chance to change the old gauges, the Dakota originally comes with, against the already bought new gauges from RXP. Because with some effort even the A36 and B58 worked fine. Unfortunately this confident mood didn't last very long. My sim was nearly loved to death by this install. For first time I had scenery.cfg file errors (!), when starting an aircraft ( curiously enough only DF B58). I checked the scenery.cfg multiple times. All fine. Even Scenery Config Editor (great tool btw!) stated: "no errors". Every attempt to start the Dakota ended with CTD. After reinstalling the RXP-Gauges, deleting all scenery.dat files and most of all uninstalling the Dakota my sim recovered. 

Afterwards I installed the Dakota again without installing the old RXP-gauges. FS9 hung up during start. Replacing every gauge didn't solve the problem. But now I also suffered OOMs, which I luckily never had before. The Dakota is stubborn. Only if I delete all the 2d panels and views in the panel.cfg I even can load the Dakota and go flying with her. But then every attempt to enter the menu or change to another aircraft leads to a CTD. By no means stable. I assume that the Aircraft needs the internal config tool provided by DF. 

I read dozens of threads about the Dakota and other DF products on Win7/64 bit; in the end I'm really confused. With regard to the Dakota it's obviously not enough to substitute the RXP-Gauges and delete every reference made to the old gauges in the panel.cfg.


Now my question for you, as I believe many of you like the Dakota and surely have more technical knowledge than me: Is there anybody who can use the Dakota on Win7/64 bit without CTDs? What is your secret?


And does anybody fixed the problem that there are nearly no visible vc window reflections? In the A36 and B58 from Dreamfleet the reflections contributed much to immersion, but honestly the Dakota seems unlifelike compared to the other products. 


Thanks for reading this. Any help is much appreciated.



Share this post

Link to post
Share on other sites

As you've touched on, the only reason the Dakota has any compatibility issues, is down to the fact that it comes with the RXP430 included with it, and that gauge has issues in FS9, on a 64 bit operating system.


You said you'd uninstalled the RXP gauges but you also mentioned buying them - so I'm wondering if you realize that the RXP430 does come packaged with the Dreamfleet Dakota anyway (but tied only to that aircraft).


You could try going to the panel.cfg for the Dakota and searching for - and deleting - all references to 'rxp' gauges.   You could then substitute the RXP430 units in the panel,cfg with other '430' gauges (such as the 'lite' ones provided by Carenado.  FS Panel Studio of course makes this work so much easier, but even if you don't own it, replacing the RXP430 gauges in the Dakota with an alternative gauges, is quite straightforward.    - just replace the gauge name but leave the dimensions the same.

For example, here's a (fictional) gauge entry for the RXP430:-

gauge00=rxpGNS!GNS430,  7,3,486,233


....so if you replace the part in red above, with an alternative gauge, you will replace the RXP and will likely see your issues disappear.


PS..... The RXP430 will also be present as a pop-up (2D) gauge within the panel.cfg too, so that will also need replacing.


If you own a Carenado aircraft that uses their GNS430, then the gauge name is :-



Good luck! 

Share this post

Link to post
Share on other sites


thank you very much for your detailed response - especially for your tip regarding the GNS430_nc1 from Carenado. I indeed own every aircraft from Carenado they made for FS9. Perhaps I will try to transfer their GPS into the Dakota's panel.


It seems my descriptions while starting this topic were not clear. Sorry for that. I know that the planes from DF came with their own RXP gauges tied to the particular plane. But the Garmin trainer software, which was always needed by the Garmin suits from RXP, was 8-bit-Software. That was why one had to buy all the expensive gauges once more in their current version, which can be used even with Win7/64 bit. So with help from friendly people like you I managed to revive my A36 and the B58 from DF.

But substituting every gauge - even in the 2D panels - does not seem to work in case of the Dakota. It's hard to understand for me. I installed the newest version of GNS430 from RXP and it does a good job in a few other aircraft (including Dreamfleet's A36), but the Dakota refuses to work properly.

Any further help is very much appreciated.


Share this post

Link to post
Share on other sites

I have the DF Dakota working on my Win 7 64 system, but I had to completely remove all the DF versions of RXP gauges (everthing!). This means not only the GNS gauges, but the VOR's, ADF, Manifold, etc. All the Reality XP INI files have to be re-created for the newer versions. It took me a while to get it working but it can be done.


However, having said that, I rarely fly it nowadays!

Graeme Butler

Share this post

Link to post
Share on other sites

Thanks, Graeme!

At least I know now that it really can be done. Since a month - whenever I get round to it -  I edit the panel.cfg files (1024,1280 and 1680) of the Dakota, removing all references to the old RXP-gauges. I inserted the newest Flightline-T, Flightline-N, GNS 430-gauges from Reality XP - to no avail. 

As the GNS 430/530 WAAS gauges from RXP seem to be rather critical, I even supposed it could be a licensing problem or a failed installation. Therefore I did a reinstallation of all the RXP stuff and actually the gauges work in other planes of mine.


Grame, or anyone else,  would you mind to send me your panel.cfg files or post it here? This would be of great help to me. As I understand from blanked out entries in those files DF expressly allows users to share a modified panel.cfg).

Thanks in advance!



Share this post

Link to post
Share on other sites

Graeme, Craig and everybody who cared,


my problem is solved. Graeme sent his panel.cfg file to me, but actually it was identically equal to mine.

But as requested he kindfully provided his RXPGNS.INI file, too - and that did the trick. I really don't know why it didn't work for me before. I can only suspect that the RXPGNS.INI created after the installation of my RXP GNS430 conflicted with the configurator which Dreamfleet built for the Dakota - and which among others determines what kind of navigation database the GNS is actually using (International or Americas). Without this RXPGNS.INI by Graeme I suffered from CTDs.

So, thanks again for your kind help! I appreciate it a lot.




This is the RXPGNS.INI that works (maybe it can help others, too):



Share this post

Link to post
Share on other sites

  • Tom Allensworth,
    Founder of AVSIM Online

  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.

    $8,560.00 of $25,000.00 Donate Now
  • Create New...