Sign in to follow this  
francy25

Comunication problems between P3D and X52 Pro

Recommended Posts

Hi,

 

Some days ago I've installed the last release of Saitek X52 Pro drivers & SST Profiler (vers 7.0.39.0)  and since then the buttons and the switches (only them, the axes are working well) has stopped working. 

Through the control panel of windows buttons pression is registered and also on X Plane 10 & DCS everything is ok but P3D (V2.5) just doesn't see them. 

I have already tried to do a complete reinstall of the drivers (deleting both folders and reg. keys) but the problem persists and regenerating control.xml/P3D.cfg files. 

I use Madcatz profiler with P3D for my key bindings. 

Someone can help me finding a solution?

My P3D installation is quite fresh and works well (good perf, almost no crashes, ecc) so I would perfer not reinstalling everything. :wacko:  :mad:

 

Thank you in advance

 

Francesco. 

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Hi Francesco

 

I have encountered probably the same situation (within the main programming wondows of the SST software everything is looking fine i.e. on pressing a button or moving a slider the respective button/Slide becomes highliged; but no signals are recorded in the test window on pressing any button resp. moving sliders [whereas mouse buttons/keyboard strokes are echoing correctly] and no signal transfer to P3D). Therefore I have tested a bit around with other/older versions of the driver and especially of the SST Profiler software. Thereby I figured out that in my situation the following combination is running

Driver Version 7.0.39.0

SST Version 7.0.27.13

 

You can download all versions at ftp://ftp.saitek.com/pub/software/full/. I don't know whether you already are aware of that.

 

In your situation you probaly just need to deinstall the SST software and reinstall the older version.

 

Good luck and give me feedback if you should figure out another, probaly more up-to-date combination

 

Andreas

Share this post


Link to post

Hi Andreas

 

Thank you for your answer!

I'll try your solution, for now I have solved the problem through FSUIPC assignment (so bypassing SST), however this solution doesn't allow me to change through modes.

 

Thank you again

 

Francesco

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this