Sign in to follow this  
hopskip

Spoiler deployment on moving yoke. FSUICP? FSX Default Axis?

Recommended Posts

Recently I was trying to add some FSUICP axis assignments to my Saitek Throttle Quadrants, the idea being that as I move across my fleet of addons, it is sometimes useful to have 2 engine throttles and 1 spoiler (777, 737NGX, Maddog, A320 etc) and at other times it is more useful to have other assignments (ie, 1 throttle, 1 mixture and 1 prop rpm for A2A C182, 2 throttles and 1 axis running both prop RPM's for the Q400, 3 throttles for MD11, etc) and found that you could assign "Aircraft specific" profiles through FSUICP.

 

So I assigned the settings I wanted for my DH8D, worked perfect. P28A Cherokee, perfect. C172, C182, MD11 all working perfect.

 

Now by using the default axis assignments, I had 2 throttles, and 1 spoiler axis on the yokes. Of course the Lancair Legacy has Prop RPM, Mixture, Throttle and a "Switch" for spoiler (it's either up or it isn't) but of course the clash between FSUICP and Default axis happened and "Mixture" was now a speedbrake and mixture. Mixture full rich? - spoiler open.

 

So Deactivate the default axis. Easy.

 

Now to make a spoiler axis for the 777 and 737.

 

Unfortunately, now with the FSUICP axis assigned and FSX one deactivated, the spoiler axis for the 777 and 737 stopped being an axis, and started acting like a switch. The spoilers were either up, or fully deployed, with an activation point just below the "spoiler retracted" position. Move the handle an inch, FULL SPOILER. move it back the width of a human hair, SPOILER RETRACTED.

 

I actually flew it like that a little while before I got sick of it, and decided to delete the FSUICP profile, and go back to using the default FSX assignment for spoiler.

 

 

AND NOW not only does the spoiler not work at all (Spoiler is fully retracted regardless of the position of the Saitek Quadrant lever position) I'm getting a full spoiler activation when I turn the yoke left or right more than about 80% of it's travel throw.

 

  • Moving the yoke left or right past 80% of travel causes full spoiler activation, including animation of the "Spoiler handle" moving to the fully aft position in the cockpit. This occurs airborne or on ground.
  1. Moving the yoke back to centre does not retract spoiler.
  2. Moving the Saitek lever through its full range of travel does not retract the spoiler (it moves slightly in 'spikes' while the lever is moving, but snaps back to full open spoiler as soon as the lever stops moving, regardless of position)
  3. The only way to retract the spoiler in this condition is the "/" key on the keyboard.

Does anyone know why this would be or have any advice?
I'd also be up for completely uninstalling FSUICP if need be, although I'v got lots of useful stuff in there regarding wind smoothing, VAS monitoring, etc. I'm sure I can set that up again if need be.

 

That said, I've removed the profile I set up for the 777-300ER, and never actually set one up for the 777-200LR/F and the issue is happening there anyway.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi,

 

I had a problem with the trim axis on my VRAC Throttle quad. Never found a fix, it was reversed and no matter what I did (reverse - checked / unchecked) it didn't work.

 

Make sure you remove all the hardware commands from FSX, Sounds like you have FSX and FSUIPC sending two different commands.

Share this post


Link to post
Share on other sites

If I understand you (the OP) correctly, when you say "default axis", you mean the axis as shown in the FSX settings for Controls?

 

that has never worked for me......using both FSUIPC as well as the FSX Controls interface!

 

If you ask me, you either use the FSX interface (with a checkmark in "enable controller") or you use FSUIPC (with NO checkmark in "enable controller")

 

The FSX interface keeps reverting to default settings every time FSX does not close correctly (which is often on my end), so I use ONLY FSUIPC.

 

 

Deleting all your FSUIPC settings is no fun, but maybe it is required.

You could just CUT your whole MODULES folder from your FSX folder and PASTE it somewhere else.

When you then start FSX things should be as if FSUIPC was never there.

If things are normal at that point then you at least know your problem is FSUIPC related and not FSX interface related.

 

 

As to your problem:

The only way you can have spoiler (handle) activation by a roll input is if your spoiler axis is checked for the wrong controller.

So make sure that when you select the x-axis or y-axis for spoiler in the FSX interface, that you are doing it for your Saitek trottle quadrant. Choose "Saitek Pro Flight Throttle Quadrant" from the dropdown list before you assign things.

Then check and make sure that "spoiler" is not selected when you choose your yoke from the dropdown list.

 

Calibrating spoilers from within FSUIPC works fine for me.

Note: I use a home made 777 throttle quadrant for the 777, (not my Saitek Throttle quadrant).

On previous versions of the 777 I had trouble to get it to work, but I think after SP1 it worked just fine.

So under axis assignment, I have selected "send direct to FSUIPC Calibration" and then "spoilers" from the dropdown list.

On the Joystick Calibration page, I have simply set the max and minimum and left the center field at -512/-512. My home made trottle does not require Rev to be checked.

(even spoiler arming works).

Share this post


Link to post
Share on other sites

I'll take another look. Having a "Yoke axis" assigned to "Deploy spoiler" certainly is how it is acting.

 

Oddly, other aircraft (737NGX for example) is not displaying this behaviour, suggesting that there isn't any spoiler axis associated with yoke in the FSX Default settings.

 

Maybe a yoke axis got a spoiler axis in FSUIPC though.

 

I think I'll try:

 

1: delete all FSUICP control & calibration profiles.

2: Check if the issue happens still

 

if so

3: Delete FSUIPC entirely

4: Check if the issue happens still

 

if so
5: Delete all control assignments for all FSX axis assignments entirely

6: Check if spoilers deploy with any yoke action.

7: re-assign yoke only

8: check if spoilers deploy with any yoke action.

 

If all that works out, I'll reinstall FSUIPC and carefully 1 axis at a time and test each time a new axis is assigned.

 

delightful hours :(

Share this post


Link to post
Share on other sites

If you are going to delete all FSUIPC calibration settings, then you might as wel delete the FSUIPC.ini file.

This does the same.

 

And upon next FSX a new, fresh, empty FSUIPC.ini file is then automatically created.

This process has cleared many strange problem for many users and is also recommended by PMDG (intro manual).

Share this post


Link to post
Share on other sites

Deleted FSUIPC.ini and reassigned everything from scratch. Everything back to normal again.

 

... now to reassign all my unique profiles again. Spent a good 2 hours on Sunday doing exactly that, Got about halfway there :P

 

 

For those reading, FSUIPC.ini is in the (Where FSX is installed) \Modules folder. There's a file called FSUIPC.dll and FSUIPC.ini. You may need file extensions to tell the difference (or just click on the file and see the full name/type).

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this