Sign in to follow this  
BrettT

Help with connecting ASN across network (no AItraffic.exe)

Recommended Posts

Hi,

 

I have been trying to get ASN to work across a local network (win 7-64).  I have believed that I have followed the directions completely but it still doesn't see the simulator on the server. 

 

In looking at the manual it says to try the AITraffic test which is supposed to be in the SDK folders but it isn't.  I found the AITraffic files/folder but there is no AItraffic.exe

 

I have successfully got Simpluggins Panel builder to work perfectly across perfectly between the two computers.

Any help would be appreciated.

 

Thanks,

 

Brett

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Some things to maybe help. make sure you have all simconnects on your client machine. 905/242/259/608. You need the original sdk from the fsx disk. It has all the tools. Update that sdk to SP1A. The ai exe will be in the sdk/core utilities/simconnect sdk//samples. Next make sure you have a simconnect ini and cfg file in your client document folder. Make sure the cfg file in documents has the correct ip or server name. Make sure you have a simconnect xml in the app/roaming/lm/p3dv2.5 folder with correct info such as the server ip address....On the server in Documents, have a copy of the simconnect cfg there too. I set up my ports...500 for simconnect on both machines. Launch p3d v2.5, let it start up and then exe the ai.exe on the client. If it connects, the screen will begin to populate with ai's, you'll see it on the client. Leave the screen open and watch it. As ai's populate p3dv2.5 , they will begin to show up on the ai.exe screen on client. Just give it a minute. If everything works, then the simconnect is configured and hopefully you will be able to launch asn on client. It has been a nightmare for me and I just had to try and figure it out.

Hope this helps....:)   I am no computer whiz..

 

Good luck. Maybe the asn connect will turn green for you as oppose to "waiting for simulator lol

 

Bob Morehead

Share this post


Link to post
Share on other sites

Thanks Bob!  Let me get this straight....I can't use the SDK from the Lockheed Martin sight I have to use the one from the original FSX disk?

 

Not sure if I have something wrong with my sharing.  I can see the folders on the server fine it seems but they are not in the "homegroup" but are in the network\\Brett-Simulator \\Prepar3d v2 (shared) and network\\brett-simulator\\users

 

Like you I am not a computer whiz....just working my way through it

 

Just find it strange that simconnect is working with PanelBuilder just fine across the two computers

Share this post


Link to post
Share on other sites

its my understanding you need to install the sdk from the fsx disk..It will install to program folder/microsft games/etc...i may be wrong but I think I read that in the asn documents and then upgrade the sdk..  I had  some problems with sharing, seems to me was the only way to access the client was to create a homegroup. You could do it on the server and then add the other client to homegroup from the client machine. I have two additional servers and I could see the folders on 2 two machines but one would not let me access so I did the homegroup trip and that fixed it. I think it has something to do with windows not being the best on networking.  I just use "everyone" on my property page/sharing for the folders. Let me know how you are doing. Maybe once you get the homegroup going that you can try the ai.exe if you did what I told you.  Originally when I put the sdk in and updated, I would click on ai.exe, it would open and close with the blink of an eye if you are looking,  until I did the cfg/ini/xml trip and then when I clicked on it, it remained open and ai's began to load that's when I knew simconnect was configured right. Oh well, enough's enough for now. One last thing, check and make sure your computer name and network name are identical on server and client!!! That is a must and one more last thing :)...check to make sure the time zones are set right and both machines have the same time.

 

Take care,

Bob Morehead

Share this post


Link to post
Share on other sites

Thanks again Bob!

 

So the computer name needs to be the same on both or just appear the same on both computers.  I did get the homegroup up and running just fine

 

Right now the server's name is Brett-Simulator and the client's name is Brett-PC  and they show up as these within the network as such on both computers

Share this post


Link to post
Share on other sites

Got it to work.  I believe the big culprit was the <disable> variable needed to be set to false (the examples in the folders have it as true) in the xml file.  As a relatively unskilled network user I didn't touch anything I wasn't sure of.   The manual is so detailed, I am surprised that it didn't cover this as well

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this