Sign in to follow this  
teopereira

Recurrent pressurization failure...

Recommended Posts

I always fly with random failures on (some 5 random failures each 10 hours)... Lately, in almost all flights I get a pressurization failure in which the "auto fail" becomes on in the pressurization panel, the cruise altitude and landing field altitude become dashed, the passenger masks are deployed, I get a boring beep sound almost the rest of the flight and the alternate pressurization mode or the manual pressurization mode have no effect at all... In the failures page I get "passenger masks deployed" or something like that...BTW, I can't  deactivate this failure when it happens... So, how many of you have this problem?

 

Thanks

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Have you set the bleeds to the correct position, I continually had this problem until I realized in my pre take-off check I had neglected to set the correct aircon/bleed settings.

Share this post


Link to post
Share on other sites

Yes, have the bleeds and packs all in the correct position...

BTW, I have FSCaptain installed... but I don't think it's caused by it...

Share this post


Link to post
Share on other sites

You say that the manual does not work ? Try this:

 

1) set pressurizarion mode selector to manual

 

2) open the valve and increase or decrease rate of climb/descent of the cabin.

 

3) Depending on altitude, set the correct pressure differential

 

The alarm should go off.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this