Sign in to follow this  

Recommended Posts

As a result of my last posted question ('Getting the FLT file being loaded'), for the first time I've started looking at SimConnect and immediately run into a roadblock. The SDK says:

 

Creating a Gauge using XML and C++

(...)

Copy the CabinComfort cabinet file to the Flight Simulator X\Gauges folder.
Copy the panel file to the Flight Simulator X\SimObjects\Airplanes\Lear45\panel folder.

(...)

 

Now, knowing me I'm probably blind, but I can find neither the .cab file, nor the LearJet panel.cfg. Where did I miss them?

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Using SimConnect inside a gauge means that the gauge is physically tied to the SimConnect version you develop with. If that version is not installed, the gauge will fail to load properly.

 

Lots of fun....

 

In short, what you're wanting to do... has a price.

Share this post


Link to post
Share on other sites

It's giving me stick - why am I not surprised? I have cabin_comfort.dll along with dll.xml in the root of the fsx folder and the gauge itself called from the Cessna 208B panel.cfg file For info, my dll.xml is:

 

 

<?xml version="1.0" encoding="Windows-1252"?>

<SimBase.Document Type="Launch" version="1,0">
  <Descr>Launch</Descr>
  <Filename>dll.xml</Filename>
  <Disabled>False</Disabled>
  <Launch.ManualLoad>False</Launch.ManualLoad>


  <Launch.Addon>
    <Name>Cabin Comfort</Name>
    <Disabled>False</Disabled>
    <ManualLoad>False</ManualLoad>
    <Path>cabin_comfort.dll</Path>
  </Launch.Addon>

</SimBase.Document>
 

I have four versions of simconnect.dll in the windows\winsxs folder. The gauge loads but all information is zero. There was an old (2010) thread about this problem but no solution. It worked first time for Bill B)

Share this post


Link to post
Share on other sites

The file dll.xml is supposed to be in the appdata area, not the core FS folder. The cabin_comfort.dll should be in the modules folder simply because there is no legitimate reason to dump it into the main folder... that's just messy by design.

Share this post


Link to post
Share on other sites

Please excuse my stupidity Ed, but after doing the following as suggested it still doesn't work.

 

1. I created a \modules folder in the main FSX folder and moved cabin_comfort.dll to there

2. I moved dll.xml to C:\Users\Flight Simulator\AppData\Roaming\Microsoft\FSX (actually added it to the existing dll.xml file)

 

'Flight Simulator' is the user for that particular account - it's not a typo. CabinComfort.cab is in the \gauges folder.

 

[Edit] Just for a test I put cabin_comfort.dll back in the FSX root folder. On startup I got the 'do you trust this?' dialog but nothing else changed.

Share this post


Link to post
Share on other sites

You forgot to put the Modules folder in the Path entry in the dll.xml file... that's why it wouldn't load until you moved it to the root folder.

 

As for the rest, I'd have to look at the code.

Share this post


Link to post
Share on other sites

Ooops... adding the path does help. I was going to attach a debugger this morning but realised I'd need to start changing the compiler instructions and I wasn't willing to (inadvertantly) make things worse. If you can find the time I would be grateful if you would take a look - the rar package is here:

 

https://www.dropbox.com/s/yehuty3e6hklbd5/Cabin%20Comfort%20Gauge.rar?dl=0

 

Package size should be 9,920,761 bytes. The dll.xml, panel.cfg, cabincomfort.cab and gauges.h are all included. It is absolutely bog-standard FSX/P3D code, which is what is making it so frustrating!

Share this post


Link to post
Share on other sites

Found the issue.

 

In your dll.xml edit you forgot to add two lines. Your dll.xml entry is this:

 

  <Launch.Addon>
    <Name>Cabin Comfort</Name>
    <Disabled>False</Disabled>
    <ManualLoad>False</ManualLoad>
    <Path>modules\Cabin_Comfort.dll</Path>
  </Launch.Addon>
It should be this:

 

  <Launch.Addon>
    <Name>Cabin Comfort</Name>
    <Disabled>False</Disabled>
    <ManualLoad>False</ManualLoad>
    <Path>modules\Cabin_Comfort.dll</Path>
    <DllStartName>module_init</DllStartName>
    <DllStopName>module_deinit</DllStopName>
  </Launch.Addon>

Share this post


Link to post
Share on other sites

Worse than that Ed - the documentation specifically says 'do not leave them out'!!! :blush: Thank you very much for spotting that.

Share this post


Link to post
Share on other sites

No problem. Wish I had people who could fix my code. LOL

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this