Sign in to follow this  
angeli662

MCE problems in full screen mode

Recommended Posts

MCE latest version 6.52 is causing video graphics to break, no problems  in window mode. any suggestions?

 

thanks

 

 

 

 

FSX-SE

Windows 10 pro

Intel 5960X @ 4.6

65 gig @ 2800

3xNvidia GTX titans sc

3x30" displays @ 7922x1600

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

MCE latest version 6.52 is causing video graphics to break, no problems  in window mode. any suggestions?

 

thanks

 

 

 

 

FSX-SE

Windows 10 pro

Intel 5960X @ 4.6

65 gig @ 2800

3xNvidia GTX titans sc

3x30" displays @ 7922x1600

 

Could be just a coincidence, new installation = new issue.

 

MCE itself runs completely outside the simulator process. Only fsInsider.dll runs inside "fsx.exe", and the latter doesn't have graphics related code at all.

 

Simply rename "fsInsider.dll" to "no-fsInsider.dll" and not a single line of our code will run inside FSX-SE.

 

See if you experience the same behaviour.

 

What aircraft are you flying?

Share this post


Link to post
Share on other sites

Thanks Gerald, all crafts do the same,  To be honest this installation has been the best I ever had in wind 10 pro :smile:

I made a quick video to represent what I am experiencing:   

maybe you could shine some light.

 

Thanks again

Share this post


Link to post
Share on other sites

 

 


maybe you could shine some light.

 

OK, thanks.

 

Maybe a new MCE under Windows 10 issue, you never know.

 

Could you please revert to single monitor and test again?

 

Another thing you could try to get it running in triple screen without displaying UI at all.

 

Go to <General> tab of the user interface and click <More options> button.

 

In "advanced options" screen, select option "Start to tray".

 

Restart the sim and MCE, and don't use the tray menu to call the UI. Your co-pilot will be there.

 

See if there is a similar behavior.

.

Share this post


Link to post
Share on other sites

 

 

Another thing you could try to get it running in triple screen without displaying UI at all.

 

Go to <General> tab of the user interface and click <More options> button.

 

In "advanced options" screen, select option "Start to tray".

 

Restart the sim and MCE, and don't use the tray menu to call the UI. Your co-pilot will be there.

 

See if there is a similar behavior.

.

 

 

 

Thank you that did the trick, and ran very well indeed. :dance:

 

PS just for info I also updated the drivers today but it didn't help before. 

 

Thanks again 

Share this post


Link to post
Share on other sites

Could be just a coincidence, new installation = new issue.

 

MCE itself runs completely outside the simulator process. Only fsInsider.dll runs inside "fsx.exe", and the latter doesn't have graphics related code at all.

 

Simply rename "fsInsider.dll" to "no-fsInsider.dll" and not a single line of our code will run inside FSX-SE.

 

See if you experience the same behaviour.

 

What aircraft are you flying?

I have found something intriguing, on the advance tab there is a config file, I found this section that made me think is the problem.

Could you clarify?

 

 [WINDOW]

Left=2794
Top=1212
NoActivate=1 //(1 to make sure MCE doesn't take the focus out of the sim, when the UI is clicked, 0 otherwise)
NoSound=0 //(set value 1 if you want to cut the various UI sounds emitted when clicking buttons or MCE minimises)
NoFullScreenDraw=0 //(set to 1, to avoid the occasional graphics artefacts than can happen when MCE UI tries to draw, and the sim is in full screen mode)
StartToTray=1

Share this post


Link to post
Share on other sites

 

 


NoFullScreenDraw=0 //(set to 1, to avoid the occasional graphics artefacts than can happen when MCE UI tries to draw, and the sim is in full screen mode)

 

No, that only addresses the odd 1 or 2 seconds screen disruption that happens when MCE minimizes or Maximizes while sitting behind the FSX screen and the latter is in full screen mode. And it only affects Windows 7 or earlier.

 

Starting from Windows 8, you can have MCE window sitting on top of FSX, even when the latter is in full screen mode.

 

And when you set NoFullScreenDraw=1 and FSX is in full screen mode, MCE UI turns into a black rectangle with no UI elements.

 

Your issue is more likely to go away by itself at some point when you have installed better graphics drivers that can handle 3 way SLI and extreme resolution.

 

You are using cutting edge hardware on a new emerging OS. No doubt things will be tweaked over time either on Nvidia or Microsoft side.

 

You only need the MCE UI to set your preferences now and then. Once you do that, there is no point staring at it, unless you have a non-responsive co-pilot (say to check whether it's in FLIGHT Mode or DIALOG Mode). The less you see it, the more immersive your Multi Crew Experience will be.

.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this