Sign in to follow this  
meesterlijk

FS9 does not start.

Recommended Posts

Hi Guys,

 

I need some help overhere. I use Windows 8.1 and my FS used to work great.

 

Now all of a sudden it does not start. I keeps telling me that I have to open it as an administrator.

 

When I do so, it does simply not respond. It does completely nothing. Even when I log in as administrator it does not respond.

 

Does anyone know what this is?

 

Thanks!

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

We ALL know what this is, but we can't tell you here. Please, please, google SIM WON'T LOAD

Share this post


Link to post
Share on other sites

Of course we can tell you - a recent MS update loaded a fix called 3086255 which ostensibly fixes a possible exploit in certain security media. Basically, it disables the FS9 disk 4 security measure - just like Win10 does natively.  All of you who are suffering from this 'improvement' need not remove the patch. There is a procedure to enable and disable it from the command line. You can find full instructions in the MS documentation for this patch, here: https://support.microsoft.com/en-us/kb/3086255. Take a look in the "Known Issues" section. It would be interesting to know if the procedure they outline also works in Win10.
 

DJ

Share this post


Link to post
Share on other sites

I removed the fix.

 

Thanks for your fast reply. Next time I will turn the page of this forum. Im sorry for any inconvenience that could have occurred to your life when you replied this topic. May the force be with you.

Share this post


Link to post
Share on other sites

No inconvenience at all - the article I referenced is an official MS document, and no hack of any kind is involved so AVSIM will have no issues.  I cannot imagine what MS was thinking when they issued this patch because they knew darn well that it would make multiple pieces of software (games especially) unable to run. I would very much like someone who has Win10 use the technique(s) mentioned in the article to see if that OS will react in the same way.

 

DJ

Share this post


Link to post
Share on other sites

Guess I need a little more help with the command line. How? Which line do you use for the fix and how do you enter it on the command line? Sorry for the duh! mode.

Share this post


Link to post
Share on other sites

Run CMD with admin privileges.  To make the  whole process automatic, open the CMD prompt as above and type "sc config secdrv start=auto" and return.  Then it should start up when it senses CD4 in the drive.  You can make your setting permanent by running regedit and finding the "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\secdrv" key, right clicking the "start" parameter choose "modify" and change the '4' to '2'. If you don't know how to do any of these things then simply go to the control panel and uninstall the patch. If you do, be aware that Windows Update will try to re-install it in the next update cycle - you can stop that by unchecking the patch and right clicking on it and selecting 'hide'.

 

DJ

Share this post


Link to post
Share on other sites

Thank you very much for taking me by the hand! Had errors using command line, so use regedit and that did the trick! Everything is working now. Again tnks very much

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this