Sign in to follow this  
Monjardino

SAITEK X55 Rhino ISSUE - Reverse Thrust AND Speedbrake Activiation.

Recommended Posts

Morning one and all,

After much deliberation I took the plunge on Friday and bought the X55 and 'wasted' (in my fiancées eyes) the weekend on FSX configuring the controls.

 

Having not being able to get the throttles to work on the Aerosoft A318/319, I gave up and moved onto the PMDG 737NGX and 777 with much more success. However, I knew before buying that the X55 doesn't have a reverse thrust detent, I've set the Speedbrake thumb slider on the throttle for that.

The issue I'm having is that when I take the thottles back to idle, a bit of reverse thrust is kicking in, the speedbrakes are deploying and V1, Vr & V2 are getting thrown out of the FMC.

 

Over the course of the weekend, I was trying various things to get the Aerosoft throttles to work and off the top of my head I can't recall how things are currently setup for General FSX use. I was a bit reluctant to use FSUIPC at first, if I'm honest I don't really understand it however, I have used it to map the throttle for 'axis throttle set 1' (left hand throttle) and a 'axis throttle set 2' (right hand throttle). I know that I mapped it through the H.U.D. Software, FSUIPC and calibrated it through FSX itself so I'm assuming that there's a conflict somewhere along the line with softwares.

 

I was wondering if anyone else is having or has had the same issue in the past and can shed any light on the culprit before I go forth and 'waste' more time in trying to find the issue and hope I stumble upon it.

 

Many thanks in advance for any help that anyone can give me.

 

Luke

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Although i do not have the X55 but rather the X52 Pro i had to delete all the joystick axis assignments in FSX, using both caused problems and ctd`s so i use FSUIPC only for calibration and axis assignment, i also found it was ok to assign buttons in FSX, as for the Aerosoft make sure that under FADEC tick inverted axis and throttle axis count is set to 1 with the Airbus configurator, then inside FSUIPC setup all your cfg for speedbrakes and throttles, i map to 4 throttles then set up the calibration and reverse thrust. i used a PDF called SIMSAMURAI FSUIPC TUTORIAL  which has a great tutorial on setup for CH throttles and rudders, but is applicable to any joystick setup.

 

Hope that helps..

Share this post


Link to post
Share on other sites

Hi Rick, thanks for the link to the tutorial, I'll definitely check it out and finally get to grips with FSUIPC. So by the sounds of it, I'm best off scrapping all axis assignments on H.U.D, FSUIPC and FSX and starting from scratch just using FSUIPC?

 

With regards to the Airbus bits you mentioned, would that be done in FSUIPC or the Airbus Configuration program?

Share this post


Link to post
Share on other sites

Hi Rick, thanks for the link to the tutorial, I'll definitely check it out and finally get to grips with FSUIPC. So by the sounds of it, I'm best off scrapping all axis assignments on H.U.D, FSUIPC and FSX and starting from scratch just using FSUIPC?

 

With regards to the Airbus bits you mentioned, would that be done in FSUIPC or the Airbus Configuration program?

just make sure the airbus configurator program has those 2 options set as above, then just use FSUIPC for everything else, sorry i edited my post. I`m not sure about the HUD programing software, maybe someone could chime in on it, but for stability i would use FSUIPC, it rocks...

Share this post


Link to post
Share on other sites

Great, thanks for your help Rick. I'm just reading the guide to FSUIPC now.

I can recall setting the throttle count to 2 in the Airbus Configuration program on Saturday, so I'll be sure to rectify that.

Cheers!

Share this post


Link to post
Share on other sites

Great, thanks for your help Rick. I'm just reading the guide to FSUIPC now.

I can recall setting the throttle count to 2 in the Airbus Configuration program on Saturday, so I'll be sure to rectify that.

Cheers!

So i should have mentioned if you choose to split your throttles and use each individually then yes your correct, set throttle count to 2 in the Airbus Configuration program , sorry about that... but also i would think you will need to map each throttle independently inside FSUIPC and maybe tick the inverted tabs also for reverse thrust to work.

Share this post


Link to post
Share on other sites

For a while when I was working through a few kinks the flight would load with engines idling, nudge the throttles and they'd both shoot to 50% N1 and the that would be my idle setting on the throttle unit itself. Taking the throttles to max power would then obviously increase power to 100% in sim. Ticking Invert (Airbus) or Reverse (FSX) would then flip things, funnily enough. So nudging the throttles would send them to 100% in sim but idle throttle position but pushing the throttles fully forward would reduce power to 50% N1.

At the point I decided to venture into the merky world of FSUIPC and managed to assign my thottles in there however it worked for PMDG and all other aircraft except the Airbus.

Share this post


Link to post
Share on other sites

Morning,

Just a bit of an update. Last night I delved into FSX, deleted all joystick axis assignments and then went through the process of axis assignment and calibration using FSUIPC. Initially I was having very odd results but after a handful of deletes and restarts, this started to improve however I was still getting reverse thrust and Speedbrake activation in the 'idle' position.

During the calibration phase on the throttles I then ticked the 'No Reverse' box in the top left of the panel, saved the calibration and entered the sim, I STILL had reverse thrust. Then, and I don't know why, I decided to set the MIN band a tiny bit forward of the fully aft position. So I entered the calibration screen, entered the MAX settings but when it came to the MIN settings I nudged the throttles forwards ever so slightly, I think the MIN figure read 16, then press SET, saved the settings, entered the sim and VOILA!!! No reverse.

I still haven't managed to get the Airbus throttles to work but I have the PMDG 737 & 777 working along with every other aircraft so I'm chalking that up as a win. I'm still looking into a fix for the Airbus.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this