Sign in to follow this  
Malcolm Wright

FSX:SE and Saitek Yoke Problems

Recommended Posts

Hi,

   As a backup system when away from my main base I use a Widows 7 Professional laptop system running FSX:SE as my flightsim.. Recently I bought another Saitek Pro Flight Yoke and quadrant because my joysticks were useless. My main system is an old Dell 32 bits running Windows XP (still the best!). I have the full yoke and two quadrants and various Saitek panels which all work well.

   I have installed the correct Saitek Drivers for my 64 bit system and as far as I can see they worked ok. However there is one problem and that is that the display on the Yoke does not show the time.

   This is not crucial except that i tend to use the timer to tell me when to start a descent.

    It occurred to me that FSX:XE is still 32 bit system so I tried to down load the 32 bit drivers but the Saitek said that it was a 64 bit machine and wouldn't let me download the 32 bit drivers.

    This may not be the reason it's not working but it's the only thing I can think of and it's not a game changer merely an annoyance but if anyone has any idea I would appreciate ttheir views.

Malcolm Wright

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Your content will need to be approved by a moderator

Guest
You are commenting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this