Sign in to follow this  
robb13

Vegn made in FSDS very dark on shadowed side

Recommended Posts

I have made a few scenery items over the years such as hangars but have always used default textures. Ive recently decided to make some vegetation scenery and just learnt how to make it transparent around the edges using my own original photos and working with FSDS and DXTBmp. The end result looks ok in FSX  on the sunny side but on the side that the sun does not hit it is very dark. I notice the default scenery has the same illumination all over and is next to the vegn scenery I created. How is that achieved. I am clearly missing a crucial step somewhere.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

You have to check assume vertical normals in the material settings. If you can't do that in FSDS you can do it in MCX.

Share this post


Link to post
Share on other sites

OK.. I have got MCX.. will have to familiarise myself with it and report back on result.

Share this post


Link to post
Share on other sites

Most likely there's a material setting in FSDS for this, you might check there first. I haven't used FSDS so I don't know, it's an SDK supported FSX material setting though.

 

EDIT: If you end up going the MCX route I think this post might be valuable:

 

http://www.fsdeveloper.com/forum/threads/halo-effect-in-grass-objects.435003/#post-720885

Share this post


Link to post
Share on other sites

Jim

FSDS does not have the 'assume vertical normals' option. It does have a Fix Surface Normals option which apparently is a different function. I have found - http://www.fsdeveloper.com/forum/threads/textures-too-dark-in-shadow-too-bright-in-sunlight.4455/ - which canvasses this issue.

Anyway, thanks for steering me in the ModelConverterX direction... I have  figured it out..

There is just one hiccup Im going to put here for other newies to this who may have same iaaue.

I just assumed that I had to import my FSDS file into MCX and change the assume vertical normals (AVN) option in Materials Editor and then I did an export as a FSX bgl file. It did not work.. so I then scrolled down the import options a bit further and noticed I could import the bgl file back into MCX so I did and repeated the process and exported again as a FSX bgl and the end result is a bit of scenery with equal illumination over 360 degrees . I did that twice and both times changing the AVN option whilst using the FSDS file did not wotk but did for the bgl.. I assume therefore that its designed to work only when a bgl is imported.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this