Recommended Posts

I have experienced a strange problem with my Saitek pro flight yoke. It worked perfectly after my first upgrade to win 10. no problems at all.

A while ago, I noticed, that the green light in the digital clock was off., and the yoke did not work any more.

at plugging in the yoke I heard the USB-sound, but the yoke was not recognized. Only the build in USB-hub was recognized.

Trying to set it up at my laptop worked perfect. no problems at all.

I have resetted my computer to a clean Win 10, but it is still not working.

When I am installing the driver, and I come to the point, where I plug in the yoke, the "NEXT" button stays greyed out.

Trying to manually install the driver from hardware properties gives only an error message from windows.

I noticed, that my laptop is running win 10 initial release build 10240 (winver), but my pc is running win 10 build 1511 build 10586.

I have grabbed the win 10 disk, I originally created at my first upgrade to win 10 (Build 10240), and reinstalled win 10, and now it works - for now!, because Microsoft is stuffing build 1511 down my throat.

Hey, the new build 1511, build 10586.122, from March 1.st. is up an running, and it seems to work!

 

Anyone have a similar experience?

Sadly FSX wont run on Linux!

 

Regards Henrik Birch

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I did. I could never determine if it was a yoke / USB / power issue or a Windows issue. It was very inconsistent. I've since replaced it with the Cessna yoke, not because of the issues but because it matches my other set of controls. Sometimes I miss the clock, but I don't miss the inconsistent operation.

Share this post


Link to post
Share on other sites

Your content will need to be approved by a moderator

Guest
You are commenting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this