Sign in to follow this  
rpowers

Autogen Question

Recommended Posts

I have been flightsimming for like 30 years and now I spend more time dinking around for improvements,solving problems etc.I know autogen has always been performance problem,but not what I am asking about.Tonight I am flying,seeing all the AG things pop up which bothers me and wonder what happens with no autogen.So I have been going back and forth between full ag and no ag.No ag nothing popping up and a lot less trees.Otherwise I see no difference.Am I missing something here like more bldgs etc?From what I see I would give up the more trees to get rid of the popping up scenery.I am obviously an old guy been doing this over 30 yrs so maybe I am missing something.Thanks,Ron

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

As mentioned "elsewhere", for buildings and tree created by autogen, add this under [terrain] in your FSX.CFG.

 

[TERRAIN]
IMAGE_PIXELS_FOR_AUTOGEN_POLYGONS=512
TERRAIN_MAX_AUTOGEN_TREES_PER_CELL=500<-----------------------adjust these two numbers as needed
TERRAIN_MAX_AUTOGEN_BUILDINGS_PER_CELL=500<------------------
LOD_RADIUS=4.500000
MESH_COMPLEXITY=80
MESH_RESOLUTION=25
TEXTURE_RESOLUTION=29
AUTOGEN_DENSITY=5
DETAIL_TEXTURE=1
WATER_EFFECTS=4

Share this post


Link to post
Share on other sites

Thanks for the reply.I used your terrain settings and looks good.1 problem.In locked spot view on grd trees and poles etc are leaning towards the rt like from heavy wind.Ron

Share this post


Link to post
Share on other sites

I understand the max trees and bldgs.what does first line image pixels polygons do?Thanks,Ron

Share this post


Link to post
Share on other sites

I understand the max trees and bldgs.what does first line image pixels polygons do?Thanks,Ron

Polyline vegetation is rasterized into a sampling bitmap. The granularity of the rasterization is determined by the following setting in the ESP.cfg file:

[TERRAIN]

IMAGE_PIXELS_FOR_AUTOGEN_POLYGONS=16

The value of this setting is set at the minimum, 16, and can be any value up to 2048. The higher the number the more accurately a curved polygon will be rasterized. The value 16 indicates a rasterization of approximately 80 meters down to approximately 0.5 meter accuracy for the 2048 setting. There is a performance penalty with the time it takes to rasterize a region, and the memory required for the resulting sampling bitmap.

Share this post


Link to post
Share on other sites

Thank you.I have no idea what any above response means.Sorry.You have it set at 512.What display differences am I looking for if I increase or decrease num?Do I assume decreasing gives better performance but lower guality and increasing the opposite?Just trying to increase my limited knowledge here.Thanks

Share this post


Link to post
Share on other sites

Correct!  The higher the number towards 2048 means more rasterization of the polygons (more work for the CPU),

 

less framerate, more stutters, etc.  Lower numbers is better for framerate but less quality.

Share this post


Link to post
Share on other sites

I originally did not have this entry under Terrain so is default 16/and you recommend 512?

Share this post


Link to post
Share on other sites

I originally did not have this entry under Terrain so is default 16/and you recommend 512?

Experiment with it!  I find 512 works for my weak system.

Share this post


Link to post
Share on other sites

Thanks for the all the help.Something to dink around with tonight while watching Fox News,basketball and golf.Multitasking withe only 1 earphone.Ron

Share this post


Link to post
Share on other sites

 

charliearon   OK,been dinking  (my sub for f word in print) around and set it to 248 assuming we are working on multiples of 4,8 or 16.Then I went to 1048.Did not notice any performance drop and everything looks good.(Could be the beers while doing this,but who cares).This is always enjoyable figuring and tweaking and LEARNING from you young gurus.Thanks Ron

 

  • Upvote 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this