Sign in to follow this  
thetford569

Graphics Files not saving or being added to the sim

Recommended Posts

I am using the latest version of SLX and when I go into my profile to specify a graphics file it doesn't save it upon reload of SLX.  When I restart it's no longer there.  It also is not adding those settings into the sim when I launch.  The latest used graphics settings are in the sim and I have to change the file manually using the in sim menu system.

 

Brandon

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi Brandon,

 

Thanks for pointing out this issue. It turned out to be a typing mistake in my code: grahpics i.s.o. graphics. I will release a new version asap.

 

Maarten

Share this post


Link to post
Share on other sites

Hi Maarten,

 

Thanks for fixing this.  I have been meaning to report that I had noticed the savings of graphics settings was fixed however when I load a profile and then load the sim it is not changing the graphics settings in the sim.  It's using the correct config file but it's not changing the settings in game.  Is there a fix for this or can you see the same on your end?

 

Brandon Thetford

Share this post


Link to post
Share on other sites

Hi Brandon,

 

Sorry for the late reply. I processed the graphics settings file, inserted the data in the config file, but forgot to save the config file. It will be fixed in the next version.

 

thanks, Maarten

Share this post


Link to post
Share on other sites

Maarten,

 

The fix for the graphics config files works and now the sim takes the correct values with one problem.....

 

I run unlimited frames on all of my config files.  When I load a profile in SLX and it then loads the corresponding graphics config file the sim takes the values however the sim shows frames per second as locked at 61.  When I go in to the settings menu the menu still shows unlimited frames but the Graphics Settings File shows "Custom" instead of my graphics file that I have saved.  I also noticed that 2D panel transparency is set to 100% which is not in my config files.  If I select the correct graphics file within the sim at this point the 2D panel transparency value drops to 0% and then I click ok and the frames per second then shows unlimited.  The sim does not have to re-load the terrain because all of the other values remain unchanged however there is something setting the 2D transparency to 100% and locking the frames at 61fps.  I have attached a couple of screenshots.

 

By the way when I load P3D without going through SLX it loads the previously saved graphics file as it should and the frames per second are on unlimited.  So this is only happening when I load the sim using SLX.

 

Brandon Thetford

 

https://drive.google.com/file/d/0B8PKlIxLCee3M2ZKRnRPZm0tU1U/view?usp=sharing

 

https://drive.google.com/file/d/0B8PKlIxLCee3cTNhb2tSSlhBRDQ/view?usp=sharing

Share this post


Link to post
Share on other sites

Hi Brandon,

 

What I do is the following:

  1. I apply to profile setting to the configuration file as specified in the profile
  2. I open the graphics settings file as specified in the profile
  3. I copy each and every setting found in the graphics settings file to the configuration file as specified in the profile
  4. I copy the configuration file as specified in the profile over the fsx(-se)/prepar3d.cfg file in the %appdata%\(Microsoft\FSX(-SE)|Lockheed Martin) folder

In the next version I will change the order of the above to 2, 3, 1, 4.

If you do not want to change the target frame rate, please set the 'Target frame rate' setting in the profile to -1.

 

I suggest you do the following:

  1. exit the simulator
  2. save the %appdata%\Lockheed Martin\prepar3d.cfg file to a backup location
  3. within SLX select the Profiles window and then select 'Tools|Apply profile' on the ribbon
  4. compare the %appdata%\Locheed Martin\prepar3d.cfg file with the prepar3d.cfg file you saved in step 2 and compare these two files with the contents of the saved graphics settings file in your '[Documents]\Prepar3D v3 Files' folder
  5. let me know if you find anything that does not look right

thanks, Maarten

Share this post


Link to post
Share on other sites

I already had the target frame rate set to -1 in my profiles so I didn't change that.  I followed your instructions and compared the two P3D.cfg files.  I found that applying the profile set my UPPER_FRAMERATE_LIMIT=61 under the [Display] section and my PANEL TRANSPARENCY was set to 0 under the [PANELS] section.  The values I had saved in the sim were for the Framerate to be unlimited and 100% 2D Panel Transparency.  I am saving my backup cfg file and I am going to have P3D create a new one and also re-set some of my profiles to see if any of that helps.  I was planning on doing this anyway to see if I can fix another problem I am having unrelated to SLX.

 

Brandon

Share this post


Link to post
Share on other sites

ok I just tried this again with a fresh P3D.cfg file.  SLX is changing my UPPER_FRAMERATE_LIMIT to 61 instead of 0 (unlimited) and also changing the PANEL_TRANSPARENCY to 0 instead of 100.  I am not sure why this is happening.  I have -1 set in the profile for changing the target framerate which is supposed to not change anything.

 

Brandon

Share this post


Link to post
Share on other sites

Hi Brandon,

 

I did some tests, and it seems there's a bug in P3D that has nothing to do with SLX unfortunately (otherwise I would be able to fix it): when you save the graphics settings and the target frame rate is set to unlimited, P3D writes UPPER_FRAMERATE_LIMIT=61 into the saved graphics settings file and that's what you get if you load these graphics settings using a profile within SLX. To workaround the issue, you can set the target frame rate to 0 in the profile settings; this will properly set the target frame rate to unlimited within the sim. I also suggest you report this issue in the Prepar3D forum. I could do it myself, but you deserve the credits for finding this bug.

 

Please also note that the graphics settings file (and of course also the prepar3d.cfg file) contains a PANEL_OPACITY setting. Opacity is the inverse of transparency: if opacity equals 0, transparency equals 100 and vice versa.

 

thanks, Maarten

Share this post


Link to post
Share on other sites

thanks for the info!  I will take that issue to the P3D forum and report it to them.  I will check out the PANEL_OPACITY setting.  Thanks!

 

Brandon

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this