Sign in to follow this  
karmelk

Saitec flightyoke & pedals not responding Q400 professional

Recommended Posts

Hi folks,

 

I have recently installed the Majestic Dash Q400 and very much like to learn to fly this bird. The bird will show up in P3D v3 and, apart from the working of the ailerons and elevator (in words not responding to my saitec yoke and pedals), all seems to be working correctly.

 

I have seen various messages on this topic and have tried all suggestions however still no luck.

 

Anybody any idea on what seems to be causing this for me?????????????

 

Hope to receive a favorable reply.

 

Regards

Dirk

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Just a thought - have you started the engines? I seem to recall when I first tried this bird, I too thought the ailerons, elevator and rudders weren't working either, but seems engines needed to be running for hydraulics to work.

 

Stuart

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this