Sign in to follow this  
Claude Troncy

Sensitivity in P3D for the live camera control.

Recommended Posts

Bonjour,

 

In P3D the shortcuts for live camera contral have the same sensitivity than in FSX, but this produce in P3D a very slow motion and the function is useless.

I changed the sensitivity from 5 to 25 and now the speed is good but the motion is very jerky and the effect is not pleasant.

Is there an explanation for this behavior in P3D.

 

Cheers

Claude

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

It's mostly down to the sim (including aircraft sim). For P3D v3.2 you should use the latest OpusFSI Beta and enable the OpusPDK Interface. This will only work in VC mode due to errors in the LM P3D PDK interface.

 

Their v3 release introduced many bugs, one being the complete loss of 6DOF control for ANY custom views (includes the Opus External view) via the PDK interface. This only leaves SimConnect 6DOF control which we all know LM nearly ruined in v2. Their SimConnect response has really been effected by their updates and software changes.

 

So there is really nothing I can do other what is done now. You should use the PDK with v3 and check Spy to ensure no SimConnect exceptions occur. There have been a large number of problems introduced with the P3D v3 release and only LM can correct these. I cannot speed up their interface nor can I correct the bug that prevents eye point control in custom view mode.

 

Stephen

Share this post


Link to post
Share on other sites

Same problem with the last version. I have No SimConnect exception.

Why did they ruined the 6DOF like that ? I think you have told them and they are aware of the problem.

Anyway thanks for your quick answer.

Claude

Share this post


Link to post
Share on other sites

Hopefully they will fix the problems with the PDK interface so that it can be used again for all view modes. The PDK was introduced in the first place to provide an efficient means for eye point and view control, their SimConnect link being quite inefficient. Let's hope for a speedy fix.

 

Stephen

Share this post


Link to post
Share on other sites

I am looking at P3D v3 LCC at the moment to see if I can adjust the sensitivity for the LCC adjustments. The VC movements should be smooth using the OpusPDK Interface, I'm not sure what I will be able to achieve in other view modes due to having to use the slow SimConnect 6DOF requests due to the bug in the P3D v3 PDK.

 

Stephen

Share this post


Link to post
Share on other sites

If you could try downloading and installing (uninstall first) the latest OpusFSI Beta Version 4.65.6 and check the speed control for your LCC movements. I have increased the speed factor by x5 to allow a greater range of speeds. You should also enable the OpusPDK Interface for your P3D v3 and copy the latest OpusPDK_v3.DLL into your <P3D v3>\Modules folder.

 

As I mentioned above I cannot do anything about your sim's response to SimConnect 6DOF requests and so I cannot do anything about the eye movements for non-VC views. For VC views the movement should be smooth since the PDK interface is used, but again the response is down to the P3D v3 code and not Opus.

 

Let me know how you get on.

 

Stephen :smile:

 

P.S.

 

My camera transitions, in both VC and non-VC modes, using settings ranging from 8 to 100 seem very smooth on my P3D v3.2 system with the stock Piper Cub aircraft loaded. The actual transition depends entirely on how efficiently P3D can process the PDK (VC views) and SimConnect (other views) 6DOF requests.

Share this post


Link to post
Share on other sites

Hi Stephen,

I already have the 4.65.6 installed, do you mean that I have to download and reinstall it even if it is the same release number ?

Claude

Share this post


Link to post
Share on other sites

Yes you will have to download and reinstall, we have released a new update this morning with the same version number for you to try.

 

Cheryl


Note, I have only made changes to the LCC eye movement rates in this reposting. Allowing any ad hoc LCC movements using the dialog or dedicated controller to be made with increased rate.

Stephen :-)

Share this post


Link to post
Share on other sites

Sorry but I install the new version, then copy the dll in the module folder, and I see no change at all.

Even with the stock piper plane the motion is jerky... not so smooth than with FSXSE.

Cheers

Claude

Share this post


Link to post
Share on other sites

As I said I have not made any changes to camera transitions, that is all down to the sim and not Opus. Opus is issuing the 6DOF updates at a high rate (the same in all sims). It's all down to how efficiently these requests can be processed by the sim code.

 

I have speeded up the max rate for ad hoc LCC movements which can also be used to check how smoothly your sim is responding to the 6DOF requests. These 6DOF requests occur much faster than the human eye can discern, so the speed and smoothness you see is all down to the performance of your sim and how quickly it can process the requests and adjust its main display.

 

You could experiment with different P3D display modes (full screen or windowed) and also different graphics settings, resolution etc. You could also compare your P3D v3 and v2 performance in this respect along with perhaps FSX.

 

Stephen

Share this post


Link to post
Share on other sites
As I said I have not made any changes to camera transitions, that is all down to the sim and not Opus

I perfectly understand  the problem with P3D.

 

One thing is the transition between camera is very smooth. I only have the problem when using the shortcuts in live camera controls using a button or a key.

Certainly the process is different in this case

Claude

PS I do not have P3D V2 to compare

Share this post


Link to post
Share on other sites

Have you tried using the LCC dialog?

 

Have you got the LCC control set in Continuous or Stepped mode and tried adjusting the LCC speed slider after the changes?

 

My LCC (using the dialog arrow controls) movement is very smooth in Continuous mode at all settings of the speed slider.

 

Stephen :-)

Share this post


Link to post
Share on other sites
Have you got the LCC control set in Continuous or Stepped mode

Yes it was in stepped mode. I did not remember  that I left it like that after creating some camera view using LLC.

Now everything is smooth.

Sorry... May be to have a reminder in the shortcut control dialog one day.... :smile:

Cheers

Claude

Share this post


Link to post
Share on other sites

Thanks Claude, I will have a think about how to make the mode more visible or warn about Stepped mode.

 

Regards

Stephen :-)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this