Sign in to follow this  
bastins

Disable Saitek Radio Panel LEDs?

Recommended Posts

I see there is an option in LINDA's joystick setup page to disable individual devices.  This seems to work as expected with the Saitek Radio Panel buttons and knobs, but not with the LED displays.  Even with the radio panel 'disabled' in the device list, LINDA continues to display info on the LEDs.  As you can probably imagine, this then makes the display flicker between two sets of information when using other software to handle the radio panel.

 

Any advice with this would be appreciated; this is the only issue preventing me from using LINDA again.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I see there is an option in LINDA's joystick setup page to disable individual devices.  This seems to work as expected with the Saitek Radio Panel buttons and knobs, but not with the LED displays.  Even with the radio panel 'disabled' in the device list, LINDA continues to display info on the LEDs.  As you can probably imagine, this then makes the display flicker between two sets of information when using other software to handle the radio panel.

 

Any advice with this would be appreciated; this is the only issue preventing me from using LINDA again.

Hi bastins

 

Welcome (back) to LINDA. Are you using other software (like SPAD) to drive your Site panels? I can give you a technical fix for this once you answer.

 

If not, there are 2 parts of LINDA code currently able to display to the Saitek panel LEDS - the core GUI code and the LUA code. You say you have disabled the devices under Joystick Setup. You also need to go to the LINDA Setup page and un-check the Saitek Panels. This will stop LINDA flickering the displays. The landing gear 3 greens on the Saitek Switch panel are permanently coded into LINDA.

Share this post


Link to post
Share on other sites

Hi Hastings

Welcome (back) to LINDA. Are you using other software (like SPAD) to drive your Site panels?

Yes and no. While testing to see if I could get LINDA to not use the radio panel displays, I made sure SPAD was not running.

 

However, under normal circumstances, yes, I would like to have SPAD running in addition to LINDA. Ideally, I'd like SPAD handling the Saitek Radio Panel, while LINDA handles the Saitek Switch Panel. I tried doing it all with LINDA, but I'm not a fan of the way it handles the radio panel.

 

...You also need to go to the LINDA Setup page and un-check the Saitek Panels.

Unfortunately, this option in particular is what I'm hoping to avoid. It certainly did the trick in disabling the radio panel (displays included), but at the cost of also disabling my switch panel, which is no good.

 

It'd be perfect if there was a middle ground - switch panel enabled / radio panel disabled, to be handled by other software.

Share this post


Link to post
Share on other sites

Yes and no. While testing to see if I could get LINDA to not use the radio panel displays, I made sure SPAD was not running.

 

However, under normal circumstances, yes, I would like to have SPAD running in addition to LINDA. Ideally, I'd like SPAD handling the Saitek Radio Panel, while LINDA handles the Saitek Switch Panel. I tried doing it all with LINDA, but I'm not a fan of the way it handles the radio panel.

 

 

Unfortunately, this option in particular is what I'm hoping to avoid. It certainly did the trick in disabling the radio panel (displays included), but at the cost of also disabling my switch panel, which is no good.

 

It'd be perfect if there was a middle ground - switch panel enabled / radio panel disabled, to be handled by other software.

 

 

Hi bastins

 

You can help me understand what SPAD does better when managing the Radio Panel than LINDA.  I can use this feedback to improve the solution for all users.

 

To achieve what you are after you will need to do a little code editing. First, go to Setup LINDA and check the Developer Mode. Open the LINDA Editor and open the file \linda\system\common.lua. In left hand pane, click on ConnectSRP. Before the last 'end' of the function (line 257) enter the line:

 

SaitekRPanel = 0

 

Save the file. Then go to Setup Joysticks, disable the Pro Flight Radio Panel device and click Save. Close LINDA GUI and restart. The Radio Panel will no longer be controlled by LINDA. The Switch Panel and Multi Panel (if you use one) can still be programmed using LINDA.

Edited by ScotFlieger
Added save of Joystick change.

Share this post


Link to post
Share on other sites

Hmm, I gave that a shot, but it doesn't seem to have worked; it's still booting up the radio displays when LINDA launches (Edit: and FSX is running).

 

Just to be sure I didn't miss something:

 

First I turned on Developer Mode.  Then I edited ConnectSRP in ...\FSX\Modules\linda\system\common.lua, giving me the following:

function ConnectSRP ()
    -- Connect to Saitek Radio Panel
    -- Trying to make a persistent connection to SRP
    _logg('[COMM] Connecting Saitek Radio Panel ..')
    SaitekRPanel, radio_rd, radio_rdf =
        com.openhid(SAITEK_VID, RADIO_PANEL_PID, 0, 0)
    if SaitekRPanel == 0 then
        --_err("[COMM] Could not open Saitek Radio Panel!")
        ipc.display("[COMM] Saitek Radio Panel is DETECTED " ..
            "but couldn't be opened" , 10)
    end

    SaitekRPanel = 0
end

Saved it and closed the editor.  Then un-ticked the Saitek Radio Panel in Joystick Setup, saved the changes, and closed LINDA.  LINDA then launches with FSX, and upon starting a flight, the radio displays come on.

Share this post


Link to post
Share on other sites

And to quick jump back to your request for feedback...

 

 

Hi bastins

 

You can help me understand what SPAD does better when managing the Radio Panel than LINDA.  I can use this feedback to improve the solution for all users.

 

I actually had a few issues between LINDA and the Saitek Radio Panel, but I suspect that a couple of them were due to my own current inexperience with each.  There was one thing, however, that I know is by-design and I didn't really like: the speed of tuning a frequency.  As I understand it, LINDA updates the panel display every second, and thus, you only see your changes at that rate.  It might just be me, I don't know, but I found it very unnatural and impractical to tune the radios so slowly.  What I like about SPAD in this regard is simply that it works much more like a normal radio.  Frequencies can be tuned quickly, and the displays update as quickly.  And, of course, SPAD fixes the inherent problems with the jumpy tuning knobs.

 

As for one of the other issues that I believe is my own doing... I couldn't actually get the mode selector knobs on the left (COM 1, COM 2, NAV 1, NAV 2, etc.) to change the radio panel's displays.  I had everything mapped, and it all worked, except the mode selectors.  Both displays just stay on COM 1.

 

By the way, thanks for taking the time to offer some help.  It's definitely appreciated, as I would really like to get back to how ridiculously easy LINDA makes it to program the switch panel.  So much easier than hunting down variables and manually setting everything in FSUIPC  :wink:

Share this post


Link to post
Share on other sites

Hmm, I gave that a shot, but it doesn't seem to have worked; it's still booting up the radio displays when LINDA launches (Edit: and FSX is running).

 

Just to be sure I didn't miss something:

 

First I turned on Developer Mode. Then I edited ConnectSRP in ...\FSX\Modules\linda\system\common.lua, giving me the following:

function ConnectSRP ()    -- Connect to Saitek Radio Panel    -- Trying to make a persistent connection to SRP    _logg('[COMM] Connecting Saitek Radio Panel ..')    SaitekRPanel, radio_rd, radio_rdf =        com.openhid(SAITEK_VID, RADIO_PANEL_PID, 0, 0)    if SaitekRPanel == 0 then        --_err("[COMM] Could not open Saitek Radio Panel!")        ipc.display("[COMM] Saitek Radio Panel is DETECTED " ..            "but couldn't be opened" , 10)    end    SaitekRPanel = 0end
Saved it and closed the editor. Then un-ticked the Saitek Radio Panel in Joystick Setup, saved the changes, and closed LINDA. LINDA then launches with FSX, and upon starting a flight, the radio displays come on.

 

Sorry that that did not work. The set up I described blanked out my Radio Panel display removing all input and output. I don't have SPAD installed so I suspect LINDA, as is normal, seeks to control all HID (joystick) devices like the Radio Panel. Try commenting out the following lines by putting 2 dashes (--) in front of each:

 

-- SaitekRPanel, radio_rd, radio_rdf =

-- com.openhid(SAITEK_VID, RADIO_PANEL_PID, 0, 0)

 

Also you should shut everything down (FSX and LINDA), start SPAD for the Radio and restart LINDA.

Share this post


Link to post
Share on other sites

I gave that a try, along with starting FSX/LINDA/SPAD in various orders, but not much luck again.

Share this post


Link to post
Share on other sites

I gave that a try, along with starting FSX/LINDA/SPAD in various orders, but not much luck again.

 

 

I am running out of ideas to help you. I need more information. Please go to Setup LINDA and change debug level to Verbose and then click on Restart LAU Engine. Then email me at linda@awginfosys.net these files from your \fsx\modules folder (linda2.log and fsuipc4.log) and your 2 config-hid.lua configuration files in \modules\linda-cfg\system\ and \modules\linda-cfg\aircrafts\{your aircraft}\.

Share this post


Link to post
Share on other sites

Sure thing; the files are on their way.

 

Hopefully it won't be an issue, but I don't actually have any controls assigned right now, as you'll see in the config-hid files.  With all the playing around and uninstalling and re-installing of LINDA to troubleshoot the Aerosoft Katana (it doesn't seem to like the recent versions of LINDA), I've held off on really setting everything up.  I set/removed an assignment to create the /aircrafts/FSX Default/config-hid.lua file, but that's about it.

Share this post


Link to post
Share on other sites

Sure thing; the files are on their way.

 

Hopefully it won't be an issue, but I don't actually have any controls assigned right now, as you'll see in the config-hid files.  With all the playing around and uninstalling and re-installing of LINDA to troubleshoot the Aerosoft Katana (it doesn't seem to like the recent versions of LINDA), I've held off on really setting everything up.  I set/removed an assignment to create the /aircrafts/FSX Default/config-hid.lua file, but that's about it.

 

 

Thank you. Reply sent.

Share this post


Link to post
Share on other sites

On the subject of radio panel,  I'm running Linda and Spad.  When I'm using PMDG T7, it loads with the barometric pressure in Hg, I use inches, so I switch it to that in the T7, but the display on the Saitek panel still reads in Hg.  How do I switch the reading on the Saitek to inches?

 

Gnacino

Share this post


Link to post
Share on other sites

On the subject of radio panel,  I'm running Linda and Spad.  When I'm using PMDG T7, it loads with the barometric pressure in Hg, I use inches, so I switch it to that in the T7, but the display on the Saitek panel still reads in Hg.  How do I switch the reading on the Saitek to inches?

Gnacino

There is no conversion to InHg available (yet). Most of the world uses hPa/mb.

Share this post


Link to post
Share on other sites

I'd like to get some more time using it, but I think I've accomplished what I was looking for.

 

After adding SaitekRPanel = 0 and commenting out the SaitekRPanel initialization in ConnectSRP, and disabling the radio panel under Joystick Setup, the final piece to the puzzle seems to have been to also untick the 'Saitek Panels' option.

 

Unticking 'Saitek Panels' was the second thing I tried previously, and it disabled both of my panels (which does make sense)... but it's leaving the switch panel alone now like I want, so I'm not going to argue with it  :wink:

Share this post


Link to post
Share on other sites

On the subject of radio panel,  I'm running Linda and Spad.  When I'm using PMDG T7, it loads with the barometric pressure in Hg, I use inches, so I switch it to that in the T7, but the display on the Saitek panel still reads in Hg.  How do I switch the reading on the Saitek to inches?

 

Gnacino

 

 

My previous statement on switching the Saitek Radio Panel was incorrect. In the Saitek Library there is are 3 functions: SAI_RADIO_baro_unit_hPa,  SAI_RADIO_baro_unit_inHg and SAI_RADIO_toggle_baro_unit. These allow you to switch the units displayed. As all the buttons on the Radio Panel are assigned by default you will need to find another button to assign to the one you want. A possibility is to assign the toggle function to the OnRepeat of the frequency change button and hold the button long enough to repeat. The problem would be that it would continuously flip the toggle. Perhaps assigning the hPa to the top button OnRepeat and the inHg to the botton button OnRepeat would be best.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this