Sign in to follow this  
tonygoole

saitek x52 and mouse cursor

Recommended Posts

Hi all

 

i have p3d v3.3.5 on windows 7

 

im using a saitek x52 with fsuipc for joystick assingments, im also using ezdok for views.

 

everytime i engage full throttle the mouse cursor goes to the right hand side of the screen.

 

i try using the mouse to reposition the cursor and it just fights with me wanting to go to the right of the screen constantly.

 

i unplug the joystick and the problem is solved.

 

BUT ..... when i try to click with the mouse the computer beeps every button press.

 

i have tried all sorts and im at my wits end now

 

please someone help

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

First thing to check for is duplicate entries, fsuipc4, p3d, ezdok.

Are the cable connections ok, do you have any Saitek software running.

Have you tried going into w7 devices, to see if it's working ok

 

Bob

Share this post


Link to post
Share on other sites

thanks for the reply

 

when the problem 1st started i deleted saitek software, fsuipc, then ezdok to rule those out, but still same problem so i deleted p3d and reinstalled it. same problem.... i deleted all key assignment in p3d and it was ok for a couple of flights, then all of a sudden its gone mad again.

 

the cables seem fine, i might try deleting the joystick and re install in a different usb port

Share this post


Link to post
Share on other sites

I have a ch products yoke and rudder but do use X52 THROTTLE and the Joy Stick for extra buttons. I have put a elastic band around the connection on the throttle to give it additional support.

Bob

Share this post


Link to post
Share on other sites

put a band round it tried a different usb port. full power no problem 30 mins in to the flightcut throttle for decent and hey presto off the cursor goes again.

 

think its time to bin the joystick, its only 3 months old

Share this post


Link to post
Share on other sites

Bob is that The cable that links the stick to the throttle ..?

Sorry I didn't answer early but been to shops, yes it was.

 

Does sound like a fault.

 

 

Did you check in w7 devices to see all the buttons and movements were ok.

 

Did you calibrate the throttle in p3d.

 

Bob

Share this post


Link to post
Share on other sites

no worries Bob.

 

no i didnt calibrate it, i have the joystick unchecked as a control in p3d as im using fsuipc. (maybe i should use the axis's with p3d control and the other button with fsuipc)

 

im not sure how to do the w7 devices to check to be honest.

Share this post


Link to post
Share on other sites

no worries Bob.

 

no i didnt calibrate it, i have the joystick unchecked as a control in p3d as im using fsuipc. (maybe i should use the axis's with p3d control and the other button with fsuipc)

 

im not sure how to do the w7 devices to check to be honest.

Press 'start' look for devices and printers, you see a list with all of your devices, right click on the X52 and click on game controller settings, select the X52, click on properties. You now should see all the axis and buttons for testing.

 

Bob

Share this post


Link to post
Share on other sites

Hi bob i had a look at the device properties. Everything great except the mouse ministick.where you can set the null zones the red line that shows you if its central or not was 3/4 to the right. I wonder if its that. I centered the red line and clicked apply.... going to fly see how it goes.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this