Sign in to follow this  
B736789

Controls input delay

Recommended Posts

Hi,
A few days ago, I found out that for all of my joysticks, every time I make an input with anyone of them, it takes approximately half a second until the virtual yoke in the FS moves.
Happens both on FSX (non Steam edition) and P3Dv3.
All drivers are up to date, and also, when I try to calibrate them outside the sim, there is no delay.

I tried to configure the controls and the CFG file from scratch, but there is no effect.
Also, since the issue began, I began having lower FPS than I am used to have.
 

My game controllers:
Saitek Pro Flight Yoke
2 * Saitek Pro Flight Throttle quadrant
Logitech G940(Stick, Throttle and pedals).

 

Thanks in advance.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

every time I make an input with anyone of them, it takes approximately half a second until the virtual yoke in the FS moves.

This is by design. Set your 'Sensitivity' slider(s) to max and the delay will be zero (or close to it, I can't remember). It simulates damping. Check out my video, which looks at this is some detail.

Share this post


Link to post
Share on other sites

This is by design. Set your 'Sensitivity' slider(s) to max and the delay will be zero (or close to it, I can't remember). It simulates damping. Check out my video, which looks at this is some detail.

Thanks for your response.

It is already set this way.

Share this post


Link to post
Share on other sites

Hi,

I did have this problem too with Saitek (Logitech) Yoke and system.

After hours of searching in the FSX community I could not find the right solution. I tried the control.cfg, fsx.cfg, etc. But still after a little time and after switching off the PMDG NGX autopilot my plane was hardly able to land by hand. It took seconds before the yoke moves arrived in the VC cockpit. Fsuipc or FSX controll settings made no difference in the horrible lag for me.

I am running Windows 10 and disabling the XBOX-app did help a little. Then I started searching for other games with controlls (others then FSX). What I finaly found did the trick!:

NEVER SET YOUR VIRTICAL SYNC REFRESHRATE as it lets your controller input WAIT untill the refreshrate (picture) is sync enough.

I had my NVidia Inspector settings on 1/2 refreshrate. Changing this to "USE THE 3D APPLICATION SETTING" or "FORCE OFF) was the holy rule that gave back my full controlls on the yoke and inputs.

Allthough my late respond on this topic, I hope others my find this their solution. Hope it helps.

Greetz,

kip1967

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this