Sign in to follow this  
TLight

Connection Error CTD

Recommended Posts

Hello.

 

After a few days of using the Pilot2ATC demo with everything working well, I started getting CTD's when trying to connect to X-Plane

When I first encountered this problem X-Plane was having a bit of a moment. It seemed to have re-initialsed itself, didn't show the normal option start screen and went straight to the default Cessna. SkyMaxx had also gone back to its defaults. When I pressed 'Connect' in Pilot2ATC it popped up with "PILOT2ATC_2016 has stopped working" (Image 1)

Thinking XPUIPC may also have been affected, I deleted the old folders and reinstalled XPUIPC and XPWIDEFS. This didn't help so I changed the server address in XPUIPC to the correct IP. Again no joy.

After several attempts I was thinking of reinstalling Pilot2ATC when I noticed the information box say "Sim Connected" before the CTD (this wasn't showing before). So now I thought of grammar loading errors or Language packs. I'd previously installed the Microsoft French and Spanish speech packs and my older v4 Cepstral Linda and Callie voices (for a bit of variety) I had filled all Pilot2ATC's voice options with them.
I went to the config/voices panel and changed everything to Cepstral Linda. I pressed 'Connect' and IT WORKED!


Everything was fine until I started a flight a couple of days ago from EGNT (Newcastle UK) to LEPA (Palma Majorca). Approx 100 miles into the journey P2ATC became unresponsive. After repeated attempts to contact ATC with an altitude change there was a faint click and a .NET error (see picture 2 below). I had to close down P2ATC and complete the journey without it.

Next time I booted X-Plane (after rebooting the machine), P2ATC went back to the previous errors (image 1), I couldn't connect anymore, this time, permanently.

I went through all the previous checks mentioned above, I even plugged in my external sound card and plugged the headset into that, same error. CTD when trying to connect.

Extra info:
My Microsoft Speech settings page only shows 'Mobile' voices, not desktop voices, not sure why this is (Win 10 weirdness). P2ATC always shows the desktop voices.
The Cepstral and Microsoft voices all work in P2ATC when tested in the voices config.
When I test the voice recognition settings in the grammar helper everything still works fine.
My Voice options in the drop down boxes (config area) only show seven voices, there's no Spanish or French Male voices showing, there's also no 'default' option (Image 3).

Any ideas?


Thank you.
Brent.

Dell Laptop: I7 8Gb RAM, nVidia 760GT 2Gb DDR5, Windows 10.
Pilot2ATC 2.0.1.8 (Demo license - 2 days left)
X-Plane 10.5 Steam version.

Pictures below...
CTD error message when I press the 'Connect' button. (the original error I was getting and the same error I'm getting all the time now)
.NET error message (the message that ultimately seems to have broken everything)
An example of only seven voices (without a default option) displayed in the voice option drop downs.

 

ctd.jpg

 

altitudechange-net-error.jpg
 

Pilot2ATCVoices-CTD-voice%20dropdown.jpg

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

WOW.  Sounds like a mess.

I would suggest you download and install the 2.0.1.10 update.  That will replace all the files other than the database files and may fix the problems.  With all the other programs being messed up by something, P2A may also have been damaged.  Just install the update over the current installation without uninstalling anything.  It should work.

 

Voice wise, Pilot2ATC is a desktop program and therefore can only see and use desktop voices.  Cortana uses a proprietary TTS engine and can use either desktop or mobile voices.  That's why the windows 10 list is different from P2A's list and your Windows default voice is not on the P2A list.

 

Let us know.

Dave

Share this post


Link to post
Share on other sites

Thank you Dave, downloading now.

 

I didn't want to try reinstalling P2ATC before as I thought it might destroy the demo license.

Share this post


Link to post
Share on other sites

Brent,

If you have problems with the license, email me and I'll let you know what I need to fix it.  My email is admin@pilot2ATC.com.

 

Dave

Share this post


Link to post
Share on other sites

Hello Dave.

 

The license still works, one day left but still alive and kicking.

The update worked :smile: , it connected to x-plane straight away.

 

Unfortunately, I ran into the bug reported earlier "Unhandled exception 2.0.1.10 FO radio tuning".

 

I restarted P2ATC, It hasn't broken in the same way it did before, it now connects to the sim but acts as though I don't have the radios tuned. The drop down boxes for 'say it' are empty and it occasionally says "Check Frequency".

 

I'm restarting both P2ATC and X-Plane as I write.

 

Thanks.

Brent.

Share this post


Link to post
Share on other sites

OK.

 

Reinstalled update .10.

This time it connected but crashed within a second or two. (Image below). Everything seemed to check out ok, Sim connected, grammars installed etc but then it blew with another CTD error.

 

The unhandled radio bug reported in another thread does seem to be causing the damage, I believe it was another .NET error which caused similar damage reported in the first post (wish I'd grabbed a screen shot of it this time around).

 

Thinking the error might have caused some memory instability, I restarted the machine and immediately reinstalled update .10 again.

 

Just flew from with P2ATC from EGNV across Britain to EGNL on the West coast, ATC all the way without any issues at all.

 

The .NET bug has a lot to answer for.

 

All the best and thanks for your help. :smile:

Brent.

 

CTD2.jpg

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this