Sign in to follow this  
art5869

Wan't to buy, but I have a doubt...

Recommended Posts

Hi. I am intresteed to buy this product, but I see that requires the SP1d for pmdg 737 ngx. My question is very simple: why? First off all I have FSX boxed edition, and everybody know that the sp1d ngx is ONLY for FSX steam edition!!! So why should I install something that I don't Need? Even that, I look on my pmdg operation center, and under 737 ngx product update, with sp1c it say that I use the last version, wich off course confirme What I Just say: no need for my FSX version to install sp1d.

So I Need to know: Can I install this product only with sp1c, because if not this no use for me.

Thanks

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi Artur,

 

You can install 737 Immersion on the latest available version of the PMDG 737 on your platform. 

 

Best Regards,

Keven

Share this post


Link to post
Share on other sites

Just One question: I have also FS2crew for 737. Does the two addon are compatibile? I mean the panel.cfg doesn't mess up After installation?

Thanks again.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this