Sign in to follow this  
Mustang-242

Mapped zoom keys work only for internal view

Recommended Posts

I'm not sure if I'm the only one with this issue as I haven't seen any similar posts (but may have missed one, apologies if so). For the last week or so (through several updates), my mapped zoom buttons function perfectly on the internal CP view but don't work at all on the external CP view. All my other camera keys/axes work fine for both internal & external.

 

The buttons I'm using for zoom are the top shoulder buttons on my PS3 controller, seen by Windows as an Xbox 360 controller. Anybody have an idea why they only work on the internal view?

 

I have a pair of buttons on my yoke set up with FSX's own zoom in/out commands. These work in the external view on the CP camera (suggesting CP is not controlling the zoom), as do the +/- keys on the keyboard, so I'm not completely stuck. In the internal CP view, where the CP-mapped keys do work, I cannot use the FSX zoom keys to change the zoom, as the zoom is overridden by CP's camera control. If I try to use them, I only see a momentary change in zoom level before the camera is reset, which is expected behaviour).

 

Besides this issue, CP is running very well for an alpha. I do see occasional glitches with switching between inside/outside views but recent updates are improving that. The new announcement for alpha 2 sounds fantastic. Keep up the great work! :)

 

Regards,

 

Martyn

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi Martyn, make sure you are in ***** (ChasePlane) views to use the zoom functions.

 

I am making a report system right now that should be available in a few days to make it easier to report such issues.

 

Regards,

Keven

Share this post


Link to post
Share on other sites

Thanks Keven. I am indeed in the Outside (ChasePlane) view but the CP zoom keys haven't worked on external views for quite some time now. Only the first couple of versions I used had working zoom in external view. Same for all aircraft. Works just fine on the internal view though. Odd! Maybe a complete clean reinstall is in order. I haven't changed much with my installation but it's likely something small has caused it.

 

Here's a report from your new report function, with e-mail address removed for obvious reasons :)

----------------------------------------------------------------------------------------------------------
--------------- ChasePlane Report by x on 11/22/2016 11:38:01 PM UTC ---------------
----------------------------------------------------------------------------------------------------------
Version:                  0.1.75
PLV:                      0.1.68
OS:                       Microsoft Windows 10 Home
.NET:                     4.6 RC or later
Running Sim:              FSX 10.0.61637.0 Supported
Current aircraft:         A2A Piper PA24 250 Comanche
Current aircraft cfg:     D:\Microsoft Flight Simulator X\SimObjects\Airplanes\A2A_Piper_PA24_250_Comanche\aircraft.cfg

----------------------------------------------------
--------------- Installed Simulators ---------------
----------------------------------------------------
FSX "D:\Microsoft Flight Simulator X\"

-------------------------------------------
--------------- Preferences ---------------
-------------------------------------------
experimental_version = False
freq_ref = 120
ctrl_freq = 60
freq_trim_ms = 1
ui_refresh_ms = 500
ui_anim_duration = 0.4
view_sel_anim_in_ms = 0.2
view_sel_anim_out_ms = 0.1
view_sel_delay = 250
mouse_middle_view_switcher = True
turb_pause_ms = 1
always_on_top = False
debug_show = False
vas_show = True
vas_warning = True
vas_remaining = False
vas_warning_treshold = 400
turb_wind_amplitude = 1
startup_glob_enable = True
app_auto_launch = True
mouse_middle_cam_look = True
pause_turbs_on_mousemove = False
doors_enabled = False
mode_cinematic_duration = 30
mode_cinematic_delay = 10
mode_cinematic_vas_protection = True
focal_offset = 0
preset_transition_time = 500
boostFactor = 5
cam_speed_multiplier = 1
gyroscopic_speed_multiplier = 1
cam_turb_factor = 5
joystick_default_dead_zone = 100
user_statistics = True
auto_cpu_afinity = True
cpu_afinity = 0
show_whats_new = True
disable_advanced = False
data_overlay = False

-------------------------------------------------------------
--------------- Aircraft's Camera Definitions ---------------
-------------------------------------------------------------
CFG created on 10/4/2015 1:00:20 PM UTC
CFG modified on 11/17/2016 11:16:46 PM UTC

[CameraDefinition.0]
Title = "Right Flap"
// (Disabled by ChasePlane)HotKeySelect = 4

[CameraDefinition.1]
Title = "Right Aileron"

[CameraDefinition.2]
Title = "Right Wing Tip"

[CameraDefinition.3]
Title = "Right landing light"

[CameraDefinition.4]
Title = "Right Main Tire and tie down"

[CameraDefinition.5]
Title = "Right Fuel Tank Level

[CameraDefinition.6]
Title = "Fuel strainer and front tire"

[CameraDefinition.7]
Title = "Propeller Check"

[CameraDefinition.8]
Title = "Engine inlets and air filter"

[CameraDefinition.9]
Title = "Check engine oil"

[CameraDefinition.10]
Title = "Left Fuel Tank Level

[CameraDefinition.11]
Title = "Left Main Tire and Tie down"

[CameraDefinition.12]
Title = "Stall warning, and Pitot tube"

[CameraDefinition.13]
Title = "Left landing light"

[CameraDefinition.14]
Title = "Left Wing Tip"

[CameraDefinition.15]
Title = "Left Aileron"

[CameraDefinition.16]
Title = "Left Flap"

[CameraDefinition.17]
Title = "Static vent"

[CameraDefinition.18]
Title = "Tail"

[CameraDefinition.19]
Title = "Verify Baggage Door is Locked"

[CameraDefinition.001]
Title = "Instruments close / IFR"

[CameraDefinition.002]
Title = "Avionics and engine"

[CameraDefinition.003]
Title = "Right Seat"

--------------------------------------------------------
--------------- Cameras.cfg file for FSX ---------------
--------------------------------------------------------
CFG created on 3/9/2012 11:32:52 PM UTC
CFG modified on 11/20/2016 10:23:09 PM UTC

[CameraDefinition.012]
Title=On-Board(ChasePlane)
HotKeySelect=1

[CameraDefinition.013]
Title=Outside(ChasePlane)
HotKeySelect=4

[CameraDefinition.014]
Title=Static(ChasePlane)
HotKeySelect=5

[CameraDefinition.001]
Title=Cockpit
HotKeySelect=2

//[CameraDefinition.002]
//Title=VirtualCockpit
//HotKeySelect=1

[CameraDefinition.003]
Title=Spot

[CameraDefinition.004]
Title=LockedSpot
HotKeySelect=3

[CameraDefinition.005]
Title=FlyBy

[CameraDefinition.006]
Title=Top-Down
//HotKeySelect=4

[CameraDefinition.007]
Title=NearestTower
NoSortTitle=True

[CameraDefinition.008]
Title=FacilitiesTower

[CameraDefinition.009]
Title=FacilitiesRunway

[CameraDefinition.010]
Title=AIPlanes

[CameraDefinition.011]
Title=MultiplayerPlanes

---------------------------------------------
--------------- END OF REPORT ---------------
---------------------------------------------

Share this post


Link to post
Share on other sites

Very nice finding Martyn, I fixed it and pushed the update!

 

Let me know if that works now!

Share this post


Link to post
Share on other sites

Thanks Keven for the quick fix! Your latest updated indeed fixed it.

 

Glad to have found a minor bug, whatever it was, as I thought it was something I had done.

 

Regards,

 

Martyn

  • Upvote 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this