Sign in to follow this  
fluffybunny88

hanging issues with p3d

Recommended Posts

Hey everyone,

I am just getting back into the sim world after being away for a few years with p3d, and I went in with two feet.  Purchased the PMDG NGX and active sky 2016.  I had used them back on FSX, a few years ago but decided to make the switch to p3d.

 

Well I may be regretting that.  I am having a problem that I'm worried I wont be able to fix without hours of diagnosing and reinstalling programs.

 

First off the basics,

Running p3d 3.4 on a windows 10 64 bit machine with i7 5820K @3.3 GHZ, 16 GB Ram, dual Nvidia 980s(running in NON SLI mode for p3d), P3d has the NGX Active sky, ezdok, and my virtual airline ACARS software.  Various sim connect things, AS connect and FSUIPC for the ACARS software.  I am running the latest versions of all of the add ons, as I just downloaded them this week.

 

The Problem:

can be intermittent with no real pattern.  yep the most fun ones to diagnose.  The entire program hangs.  Not a stutter, not a glitch, hang.  simulator pauses, get the spinning wheel, then a few seconds later not responding pops up(running in window mode) then it fixes itself and we are back flying.  Whole thing lasts about 10 seconds.  It happens every once in a while with any plane I am flying, but I have mostly been flying the PMDG NGX.  It has happened with other aircraft when I was trying to figure out if it was just the NGX.  Now here is the real kicker, it happens in the menu in the game as well, for example if I go into options while flying it will happen.  It happened when I went to go change aircraft to test a different airplane.  It doesn't mater if I have active sky open or closed, ACARS software open or closed, doesn't mater, still happens.  It happening every 10 min or so I could live with, but today it happened on approach where there was some heavier weather.  Game would go for 5 seconds, then hang, then go for 5 seconds then hang.  I shut down all of my open add ons(active sky, and ACARS, and even changed the weather to clear, with no change at all.

 

I bet it is add on related and may just have to bite the bullet and reinstall the whole thing, adding one at a time to see where I have the issue, but I would really not like to do that.  I will have to test it for about an hour each add on I install.  Anyone have any advice or suggestions before I go down that path?

 

Thanks


Also:

Is there somewhere that I can check all of the versions of the sim connect and fsuipc, basically everything loading into the sim, in one place?  And where would that be?

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Do you have FSUIPC and have it set for saving flights by any chance? If so turn the save function off and see if it still happens. 

Share this post


Link to post

Do you have FSUIPC and have it set for saving flights by any chance? If so turn the save function off and see if it still happens. 

I do have FSUIPC, but it was unregistered but I solved the issue.

 

 

For future refrence I did a couple of things at once and one of these fixed it.  I updated my FSUIPC turns out it was out of date by 1 version, not sure how that happened since it was a fresh download, but it was.  I added my registration to FSUIPC also.

 

More importantly and Bobs thought got me thinking.  the ACARS software for my VA does an autosave on flight progress, I turned that off, and one of the above seemed to fix the issue.  Glad its working now!

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this