Sign in to follow this  
AviatorMan

Milviz T50 Avionics

Recommended Posts

It's a great aircraft, but I am having some trouble turning on the "modern" avionics - I have the GTN 750 installed. When I load the airplane, the GTN750 module shows in the instrument panel (and I know that it is properly installed) but it does not come on. And I cannot find an avionics or general radio switch. Anybody have a suggestion?

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Are you using the latest 750, v 1.19 and the latest garmin trainer v6.21? There is an issue with this trainer version over on simforums, for now it's recommended to go back to the 6.01 version. I had a similar issue with my a2a planes.

Share this post


Link to post

Are you using the latest 750, v 1.19 and the latest garmin trainer v6.21? There is an issue with this trainer version over on simforums, for now it's recommended to go back to the 6.01 version. I had a similar issue with my a2a planes.

Thanks for the suggestion. Not sure which version I have, but in any case the GTN750 has now started working on the Milviz T50. It started working after I had started P3D with another plane (the A2A Comanche) on which I had the GTN installed, and where it worked fine. Then, without shutting down P3D I selected a new vehicle - the T50, and the GTN worked fine. And now I can startup P3D with the T50 and the GTN is working. Not sure what was the problem before.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this