Sign in to follow this  
downscc

Long Frames Loading Airports et. al.

Recommended Posts

Thanks to Rob's excellent guide to P3D, I have my system running almost the way I want it. No micro-stutters, always fluid, textures look great, lots of scenery, landclass and most airports available for P3D (except Aerosoft, which I avoid when I can).  The problem I've been trying to resolve for many sessions are the incidence of a long frame, longer than 1 sec and up to 3 sec, that typically occurs when the airport objects are being rendered somewhere around 10 nm inbound.

 

Has anybody had success in reducing or eliminating these long frames (an exaggerated stutter)?

 

It not for the lack of performance:  i7-6700K 4.7 GHz liquid cooled, DDR4 at 3300 MHz, NVME SSD, GTX 980TI and a 42-in 4K TV at 30 Hz.  Frames locked in P3D at 20, which never dips below 19.8 except for the long frames.

 

I've tried many variations on TextureMaxLoad, SWAP_WAIT_TIMEOUT, AffinityMask, and TEXTURE_BANDWIDTH_MULT. 

 

My next trials are going to focus on the MaxRegionsPurgePerFrame, which I gently increased from default 16 to 18.

 

I sure would like to hear from someone that has already gone down this rabbit hole. Thanks.

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this