AndyH23

P3D and Steam VR

Recommended Posts

Hi.

I have an Oculus Rift and Steam VR installed. I am having issues with P3D not displaying on my monitors when launched. It has launched as it shows in Task Manager and Chaseplane connects.

Steam VR is launching with it though and I assume this is where the display in being routed even though I have unplugged my Rift.

I have unchecked all the boxes in Steam VR not to start with apps but it keeps starting.

Any ideas would be appreciated.

This maybe nothing to do with Steam VR but it would appear logical.

I have tried deleting my P3D config and fxml and wx files.

All to no avail.

Thanks.

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

So you definitely removed the tick by "start steamvr when an application starts" in the developer menu? This worked for me as was annoying me at first that it was starting when i didn't want to use the Vive in P3D

Share this post


Link to post

Why don't you just exit Steam? If Steam is not running then Steam VR will also not start.

Share this post


Link to post

Actually SteamVR can start independent of Steam itself, it did this with P3D for me as well.

Share this post


Link to post

Guys. When yours started, did it take your p3d monitor output from your screens? And yes the tick was removed from app start and Steam VR starts all on its own. When Steam VR used to start I had the option to shut it down but of late I still don't get p3d on screen. So I'm not sure what's causing the no show of p3d. Any ideas beyond this please. Losing time in QOTS which I had just mastered. Thanks again.

Share this post


Link to post

Got the same issue. "Start steamvr when an application starts" is unticked but it starts whenever I start P3D and the Oculus App then opens as well. If I quit it after launching P3D, it will relaunch once the scenario has loaded. Steam itself is not running at any point.

I can find any entries in the ddl.xml or the exe.xml within files localted AppData Roaming or the ProgramData folder that call for a launch of SteamVR either.

Anybody know what is causing this behaviour, apart from unistalling SteamVR which is not an option for me.

Share this post


Link to post

I changed the [STARTUP] field of Prepar3d.cfg.
I have made LoadVirtualReality = 0 and EnableVirtualRealityOnStartup = 0.
VirtualReality disappears in the ALT menu, but Steam VR does not start automatically.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now