Sign in to follow this  
flyforever

dx10 controller does not hold aa settings

Recommended Posts

I am stumped. I set AA in Steve's DX 10 controller, open FSX, and see that the jaggies are still present. I close FSX, go into Steve's controller and see that the AA settings have set themselves to No AA.

Can someone shed light on this?

 

I'd like to mention that I've installed the controller in a separate hardrive---where all my fsx files are located. Can this be the cause?

thanks

tony

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

In Dx10 preview the basic AA settings come from fsx.cfg.  The DX10 controller merely displays to you what the settings mean and allows you to change them in an easy to understand way - i.e all it does it write values into fsx.cfg - its the settings in fsx.cfg that matter

The 3 fields in fsx.cfg are

1) The Antialias setting in the device group  which will look something like this.

[DISPLAY.Device.NVIDIA GeForce GTX xxxx.0.0]
Mode=1920x1200x32
Anisotropic=1
AntiAlias=1

If the Antialias settings is zero the controller will show the AA as No AA.

The Antialias setting can be turned off and on from inside fsx in the settings->graphics - its the tick box labelled anti-aliasing. 

2)   The Multi Sample values in the Graphics group.    These control what the base AA is (2x, 4x, 8x etc)

[GRAPHICS]
....
MultiSamplesPerPixel=4
MultiSampleQuality=4

MultiSamplesPerPixel is the number of samples   either 2x 4x or 8x - the default is 4


MultiSampleQuality indicates if one of the  color samples AA modes (CSAA) is selected.  The default is the same setting as MultiSamplesPerPixel which means CSAA isn't set. 

It can be set to 2x or 4x the MultiSamples settings which will turn on CSAA at that level.  Trying to explain this bit gets a bit convoluted hence why I added a pulldown to select the valid options in the controller.

So I would guess that you are either 

  • replacing your fsx.cfg when running fsx
  • Changing the anti-aliasing setting inside fsx

Nvidia Inspector has no say in these settings andso  cannot controller AA in Dx10 preview mode.   All you can do in NV is select the Smart Grid Super Sampling value which should always be set to the same number as MultiSamplesPerPixel

 

 

Share this post


Link to post

It's ok, now, although I don't know what fixed it. 

Thanks, Steve.

tony

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this