Sign in to follow this  
wacopolumbo747

Saitek Pro Yoke shutting RH engine down with aileron deflection

Recommended Posts

Hi All,

I need a little help.  I an running Windows 7, 64 bit and I am having problems with my controls.  I have the Saitek Pro Yoke, extra throttle and rudders.  Everything was working fine and then one day when I turned on the computer, the Yoke and throttle wouldn't power up (rudders were fine).  I bought a powered USB hub and the controls work again.  However, when I input a right aileron deflection, the #2 (2 engine aircraft) or the #2 and #4 (four engine aircraft) shut down.  There is no visible switch the is moved and there is no action other than aileron movement and elevator movement tied to the Yoke.  I updated drivers, restarted multiple times, deleted the FSX config file and it is still doing it.  Ever since the controls stopped working, it has been doing this.  I am beginning to think the Yoke is broke.  It has done this with the PMDG 747vs and LevelD 767.  

Any help would be great.

Thanks,

Jody

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

If things are happening when you move the yoke it's probably not broke! Most likely you have mixture control mapped to the aileron axis. You don't say which sim so I will presume FSX. FSX has an annoying way of mapping axes to functions by itself, and only occasionally is this useful. I would suggest you go into the 'options/settings/controls' menu and make sure each of your analog axes is mapped to the thing you want it mapped to, and to nothing else. I predict that this will solve your problem.

Share this post


Link to post
Share on other sites

Thank you, I will check that when I get home.  Yes, FSX.  Is there a way to have FSX forget the maping? Even when I change stuff, sometimes it will still do it.  I have a registered version of FSUIPC, maybe I'll try that to program everything.

 

Share this post


Link to post
Share on other sites
9 hours ago, wacopolumbo747 said:

Thank you, I will check that when I get home.  Yes, FSX.  Is there a way to have FSX forget the maping? Even when I change stuff, sometimes it will still do it.  I have a registered version of FSUIPC, maybe I'll try that to program everything.

There is some complicated way of backing up the standard.xml file and restoring it when FSX overwrites it, but I forget the details. The best way, as you suggest, is to uncheck the 'enable controllers' box in FSX and set everything up with FSUIPC. Then you will have not problems. (Assuming that this is the problem you have!)

Share this post


Link to post
Share on other sites

When I checked FSUIPC, sure enough it had the aileron axis assigned as mixture for the #2 and #4 engine running in the background. Don't know how that happened, but it's alright now. 

Thanks for the tip!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this