macpilot

FTX Central and P3d version 4

Recommended Posts

I just purchased P3D Version 4. I have the current version of FTX Central. Is it a safe assumption that when selecting P3D version 4 in FTX Central that any scenery listed as not installed is compatible with Version 4?

 

Thank You.

 

Bill McCracken

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Tha's correct, only the ones that are already v4 compatible will be installed on P3D v4. 

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now