fjperreault

Crazy routing and errors

Recommended Posts

I am trying to create a flight plan and I am having issues with.  Here is the route I am trying to create.

KATL NASSA2 YAALL J14 LIT MLC PNH ACH ABR J78 DRK J231 HIPPI GABBL HLYWD1 KLAX

First, I enter the starting and ending waypoint for KATL and KLAX.  I then add the SID NASSA2 with the YAALL transition. Things look fine at this point.  I then click on YAALL and load an airway for J14 LIT.  My route then goes all screwy with a lot of  GCRPt... waypoints and a route that takes me to Israel. I love the country but that isn't what I'm trying to.  If you try to clean things up by deleting the GCRPt's you end up with unhandled exceptions. I am running the latest .18 version of Pilot2ATC along with the latest Navigraph database.

Now I also use PFPX for flight routing.  It also uses the latest Navigraph database.  I have noticed that some waypoints are located in multiple locations such as PNH (Phnom Penh and Panhandle (TX)).  How do you resolve this?   Is this why I am getting a route that takes me to Israel?

Frank

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Frank,

I entered that route with no problems except I had to leave out ABR as it is a VOR due West of Minneapolis and takes the flight way off course to the north and I couldn't find a J78 out of ABR.  J231 gets you from ACH to DRK, so I chose that. 

Have you  tried just entering the waypoints, leaving out ABR and all the airways?  You can come back and enter the Airways later.

Also, have you tried some other routes with success and this is the only one giving you trouble?

Dave

 

Share this post


Link to post
Share on other sites

Dave,

Because I performed an update from .12 to .18 I thought that I would blow away the install and just do a fresh .18 install to see if anything changed this situation.  So I uninstalled .12, installed .18 and updated the nav database using Navigraph.  I can now enter the waypoints without getting an error and the GCRPt's disappear as they should, while I enter in the waypoints.  As for the ABR you were having an issue, that is my error. I mistyped the waypoint and it should actually be ABQ, not ABR.  Sorry about that,

So now the waypoints go in OK which is great, with the exception listed below.  Now the goofy issue with routing I had before shows up when I try to add the airways. So at this point I have all the waypoints entered in except for those of the SID and STAR. I click on the VOR image for the YAALL entry and that brings up the waypoint menu.  Click the Load Airway option and select J14 LIT and voila, we're going to Israel, Mongolia and Africa!  So that's problem one.

Problem two, start new and enter the KATLand KLAX waypoint. Now insert the YAALL waypoint after the KATL waypoint. This will give you a bunch of GCRPt waypoints. Try to delete the YAALL waypoint and you will end up with an Unhandled Exception.  I am finding that with any flightplan, anytime you try to delete a valid waypoint and there are GCRPt waypoints in the list, this causes an Unhandled Exception. 

Here is a copy of the error message.

See the end of this message for details on invoking 
just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************
System.NullReferenceException: Object reference not set to an instance of an object.
   at P2A_2016.FltPlan.RemoveWaypoint(FPWpt Wpt)
   at P2A_2016.ucFltPln.y(Object A_0, EventArgs A_1)
   at P2A_2016.frmWptOptions.a(Object A_0, EventArgs A_1)
   at System.Windows.Forms.Control.OnClick(EventArgs e)
   at System.Windows.Forms.Button.OnClick(EventArgs e)
   at System.Windows.Forms.Button.OnMouseUp(MouseEventArgs mevent)
   at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
   at System.Windows.Forms.Control.WndProc(Message& m)
   at System.Windows.Forms.ButtonBase.WndProc(Message& m)
   at System.Windows.Forms.Button.WndProc(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

 

Let me know if there is anything I can do to help.

Share this post


Link to post
Share on other sites

FYI, I have tried several other routes and they don't go to Israel so it's hard to tell if it's a nav data issue or not.  I know that if I put in the same route in PFPX using that latest nav database I don't see an issue.  As for the Unhandled Exception, I can get that to happen pretty regularly whenever there are GCRPt waypoints in the list.

Frank

Share this post


Link to post
Share on other sites

I found and fixed a possible bug that could have caused the unhandled exception.  That will be included in the next update.

Using Navigraph AIRAC cycle 1707, I cannot recreate the problem with the round the world trip. 

 

Share this post


Link to post
Share on other sites

Looks like he has the same problem I still do with being unable to use the Airways feature or the important flight plan if the flight plan has airways in it.   I still get terrible criss-crossing flight plans that make no sense at all.    Again, I wish I knew what file, driver, or vodoo curse I have on my PC that makes it unable to unpack the airway waypoints and put them in a proper order to use in the flight.    I just did a flight plan import from Flightaware from KDFW to KJFK with the newest version in hopes that the problem magically fixed itself but it had waypoints in Australia, parts of Europe and then a wild back and forth on the east coast of the US until finally ending at KJFK.  The flight plan was like 10 pages long!  lol...    *sighs*   

Can you divulge just how P2A works when it goes to add an airway into the flight plan?   Like what kind of database is it searching?   How does it figure out the waypoints and then how does it bring those into the planner?   Something on my system is interfering with whatever method you use to get the data unpacked and loaded into the flight planner.    If I knew how it did that I might be able to pin point a patch, driver or program that could be disrupting your method.

I have had several people now on my YouTube channel ask me to do a full demonstration of using P2A and I can't full fill the request with this giant problem.  I don't want people to think this is a bug on P2A's part as viewers seeing this error might get turned off by it and I would rather shove business in your direction, not take it away.  You have worked with me to great lengths on this problem but just can't figure it out.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now