Jump to content

Sign in to follow this  
Guest Tophatter

Is there a trick to getting the Mixture joystick axis assignment to work?

Recommended Posts

Guest jeff_hanna

I can map the Mixture control (not engine # mixture, just mixture) to a slider on my X52 setup. The configuration screen in FS9 accepts the assignment when I move the slider and shows that the assignment has been made. Yet, when I fly the mixture control on the cockpit panel does not react when I move the slider on the X52. The trim, throttle, aileron, rudder, and elevator inputs all work so I know the X52 is being recognized and utilized.I have all of the Realism sliders maxed (except for torque and p-factor I feel those two are over modeled based on my real-world flying experience). I have "auto mixture" unchecked. I can't seem to find anything else in the settings that might be overriding my mixture choice.I've only tried with the default C172. Is there a known problem with axis controlled mixture on the default airplanes? Maybe I'll download a few FS2K4 planes from here and try them.Any help would be greatly appreciated.

Share this post


Link to post
Share on other sites

I use an Saitek X45, with the mixture mapped to 4-way switch on the throttle. Prop control is also on this switch. It works for all planes that use it, that I can think of.As to torque and P-factor, a lot has to do with having rudder pedals or not. With pedals, full realism works best for me. With a twist grip or rocker switch, it seems twitchy.Some 3rd party airplane designers specify realism settings, which can vary.L.Adamson

Share this post


Link to post
Share on other sites

Find the axis for your mixture control in the [JOYSTICK_MAIN] sectionof FS9.CFG. Make sure it says something like AXIS_SCALE_00=127.I Had to do this with CH Throttle quadrant to get some of the axis (axises?)recognized.

Share this post


Link to post
Share on other sites
Thought I'd help out here a little:Correct spelling is "AXES" (plural) and "AXIS" singular. Good dictionary helps a lot.No criticism intended, just being helpful.

Share this post


Link to post
Share on other sites
Guest Tophatter

After assigning the axis go to controls/sensitivities and adjust the sensitivity for that axis.Bud

Share this post


Link to post
Share on other sites
Guest jeff_hanna

I had thought about using a repeating-press button assignment. I'd rather use the slider, though. If I can't get the slider to work the repeating buttons will be my fallback. Thanks for the help.

Share this post


Link to post
Share on other sites
Guest jeff_hanna

>After assigning the axis go to controls/sensitivities and>adjust the sensitivity for that axis.That did it! The sensitivity for that slider was set to 0. Thank you, Bud!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...