Sign in to follow this  
jarhead2042

Xplane dc6 issue

Recommended Posts

have tried google and searching here with zero luck

finally caved and got the dc6 for Xplane last night. installed no problem, plane loads in the game and bam enter the activation id pops up, no problem I have that bad boy right here next to me, but no matter what I do it will not activate to save my bloody life. it will say activation unsuccessful due to wrong id or internet connection. my connection is good and I have gone over the id like a forensics investigator to make sure it was correct and it seems to be flawless. tried looking in the operations center to see if there was a way to enter it in there, but no Xplane option seems to be in there, just my 737 for p3d. have a pending ticket at pmdg but figured I would see if someone here can beat them to the fix so I can get to flying  

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Welcome to the PMDG forums, please note their rules ask us to post our full names.

I always recommend activation problems go straight to PMDG Product Support.  This is a user forum and other than give you the routine "make sure your AV or firewall is not blocking the activation process," there is nothing else anyone here can do to help you.

PMDG Product Support is here (you will have to create a support account, they are separate from sales accounts): http://support.precisionmanuals.com

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this