Recommended Posts

I'm flying on VATSIM on P3D v3. I have the most up to date version of vPilot and I use Ryan Perry's AI. I haven't had an issue until purchasing the Aerosoft CRJ.

 

Anyways, all my AI traffic shows up normally except CRJ 700s and 900s. I have my default vPilot model matching aircraft as the default P3D CRJ700. The CRJ7/9's on VATSIM as AI traffic are completely invisible. I can only see the aircraft's strobe, wing, and beacon lights. I saw that downloading the latest drivers for your GPU may help, but that did not seem to work for me. Any suggestions to fix would be greatly appreciated!

 

Regards,

Kyle

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

2 hours ago, DaveCT2003 said:

The Debug under the model matching section and see what you find.  https://forums.vatsim.net/viewtopic.php?f=16&t=64672

Best wishes.

I did the debug on an aircraft that was at ORD as I was sitting at the gate. ENY3744 is the "invisible" aircraft - a CRJ7. Below is what .debug was saying. I don't think it has anything to do with the plane being invisible. I'll attach a screenshot of what I see.

 

[21:17:05.207] vPilot version 2.1.6
[21:17:19.987] Received aircraft configuration info from ENY3744: {"config":{"spoilers_out":true}}
[21:17:20.289] Received aircraft configuration info from ENY3744: {"config":{"spoilers_out":false}}
[21:17:40.595] Received aircraft configuration info from ENY3744: {"config":{"spoilers_out":true}}
[21:17:42.120] Received aircraft configuration info from ENY3744: {"config":{"spoilers_out":false}}
[21:17:56.520] Received aircraft configuration info from ENY3744: {"config":{"spoilers_out":true}}
[21:17:58.562] Received aircraft configuration info from ENY3744: {"config":{"spoilers_out":false}}

Screenshot: http://prntscr.com/g71j1s

Share this post


Link to post
Share on other sites
3 hours ago, DaveCT2003 said:

The Debug under the model matching section and see what you find.  https://forums.vatsim.net/viewtopic.php?f=16&t=64672

Best wishes.

 

Just as I was finishing up the post, below is what popped up on debug for another CRJ7, also invisible. I don't really know what it means. Any help would be greatly appreciated! :)


[21:24:06.611] Aircraft discovered: ENY3075 - requesting CAPS, sending CAPS, requesting aircraft info
[21:24:06.978] Received capabilities list from: ENY3075 - VERSION=1:ATCINFO=1:MODELDESC=1:ACCONFIG=1
[21:24:06.980] Requesting full ACCONFIG packet from ENY3075
[21:24:07.109] Model match result - Callsign: ENY3075 - TypeCode: CRJ7 - ModelName: VPA_AIG_CRJ700_ENY-Envoy - Rule Set: F:\Kyle\Documents\vPilot Files\Model Matching Rule Sets\VPA_airline_rules.vmr - Pass: 1
[21:24:07.111] Received aircraft configuration request from ENY3075
[21:24:07.408] Received aircraft configuration info from ENY3075: {"config":{"is_full_data":true,"lights":{"strobe_on":false,"landing_on":true,"taxi_on":false,"beacon_on":false,"nav_on":false,"logo_on":false},"engines":{"1":{"on":false},"2":{"on":false}},"gear_down":true,"flaps_pct":0,"spoilers_out":false,"on_ground":true}}
[21:24:10.538] Received capabilities request from ENY3075 - sending CAPS and requesting aircraft info
[21:24:10.540] Received capabilities list from: ENY3075 - VERSION=1:ATCINFO=1:MODELDESC=1:ACCONFIG=1
[21:24:10.541] Requesting full ACCONFIG packet from ENY3075
[21:24:10.917] Received unchanged aircraft info for ENY3075 - already have a model selected
[21:24:10.919] Received aircraft configuration request from ENY3075
[21:24:10.920] Received aircraft configuration info from ENY3075: {"config":{"is_full_data":true,"lights":{"strobe_on":false,"landing_on":true,"taxi_on":false,"beacon_on":false,"nav_on":false,"logo_on":false},"engines":{"1":{"on":false},"2":{"on":false}},"gear_down":true,"flaps_pct":0,"spoilers_out":false,"on_ground":true}}
[21:24:11.574] Aircraft added to sim: ENY3075
 

Thanks,

Kyle

Share this post


Link to post
Share on other sites

Kyle,

We'll take a look at this and get back to you.  But I also want to let you know that it's highly inadvisable to ever use a payware model for AI aircraft, it will eat your frames!  Using one as a default will wreck them!

Still, it needs to be looked at, thanks for bringing it up.

 

Share this post


Link to post
Share on other sites
1 hour ago, DaveCT2003 said:

Kyle,

We'll take a look at this and get back to you.  But I also want to let you know that it's highly inadvisable to ever use a payware model for AI aircraft, it will eat your frames!  Using one as a default will wreck them!

Still, it needs to be looked at, thanks for bringing it up.

 

I appreciate it. I saw a similar issue on another forum and they suggested adjusting scenery complexity and shadow casting. Messed with both for a little and nothing changed. Just an FYI and I hope it helps you assist me in solving this issue.

 

- Kyle

Share this post


Link to post
Share on other sites
On 8/10/2017 at 11:35 PM, DaveCT2003 said:

Kyle,

We'll take a look at this and get back to you.  But I also want to let you know that it's highly inadvisable to ever use a payware model for AI aircraft, it will eat your frames!  Using one as a default will wreck them!

Still, it needs to be looked at, thanks for bringing it up.

 

Hi Dave,

 Just checking if anything was found yet :)

Share this post


Link to post
Share on other sites

No sir, not as of yet.  For the time being I wouldn't use the CRJ as an AI model... actually, as I mentioned before you really never want to use a payware model as an AI model as you'll trash your frame rates.  Take a look at the size of the airplane folder in SimObjects and compare it to any other AI model and you'll see a HUGE difference - and all that data has to be processed for each aircraft that model gets assigned to!

I used the freeware AI models for users for VATSIM, though keeping them updated was always some work.  With the release of P3DV4 I moved to Ultimate Traffic Live for and love it - and it updates itself.  It's what I recommend these days.  If you decide to go this route for VATSIM AI, then I'd advise you to install UTL and then edit the Addon.dll and change UTL Active from "true" to "false" so the UTL program won't load when you fire up the sim. This will save your processor some cycles.  The models will still show up just fine.

 

 

Share this post


Link to post
Share on other sites
On 8/17/2017 at 10:20 AM, DaveCT2003 said:

No sir, not as of yet.  For the time being I wouldn't use the CRJ as an AI model... actually, as I mentioned before you really never want to use a payware model as an AI model as you'll trash your frame rates.  Take a look at the size of the airplane folder in SimObjects and compare it to any other AI model and you'll see a HUGE difference - and all that data has to be processed for each aircraft that model gets assigned to!

I used the freeware AI models for users for VATSIM, though keeping them updated was always some work.  With the release of P3DV4 I moved to Ultimate Traffic Live for and love it - and it updates itself.  It's what I recommend these days.  If you decide to go this route for VATSIM AI, then I'd advise you to install UTL and then edit the Addon.dll and change UTL Active from "true" to "false" so the UTL program won't load when you fire up the sim. This will save your processor some cycles.  The models will still show up just fine.

 

 

Thanks for the help!

Share this post


Link to post
Share on other sites
On 8/17/2017 at 10:20 AM, DaveCT2003 said:

No sir, not as of yet.  For the time being I wouldn't use the CRJ as an AI model... actually, as I mentioned before you really never want to use a payware model as an AI model as you'll trash your frame rates.  Take a look at the size of the airplane folder in SimObjects and compare it to any other AI model and you'll see a HUGE difference - and all that data has to be processed for each aircraft that model gets assigned to!

I used the freeware AI models for users for VATSIM, though keeping them updated was always some work.  With the release of P3DV4 I moved to Ultimate Traffic Live for and love it - and it updates itself.  It's what I recommend these days.  If you decide to go this route for VATSIM AI, then I'd advise you to install UTL and then edit the Addon.dll and change UTL Active from "true" to "false" so the UTL program won't load when you fire up the sim. This will save your processor some cycles.  The models will still show up just fine.

 

 

Dave,

Last time I will bother you, but it is for good reason :)

 

I solved the issue, I just simply had to get the latest version of Ryan Parry's AI for vPilot and everything is now working as usual. I appreciate your help and I hope this assists you in further instances.

 

Sincerely,

Kyle

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now