foges

FPL sequencing issue/bug [solved]

Recommended Posts

 

Firstly Jean-Luc and the guys - great job !!

 Have been waiting for this since Christmas and it hasn't disappointed.

I swung over to P3D some time back but have been frustrated with no realistic 430 to practice IFR. Don't expect to get the 10+ years of use I got out of version 1 but am looking forward to pushing it.

Have come across an issue that I'm pretty sure is a bug.

I first noticed it when I added an approach to a flight plan then couldn't get the Autopilot to pick up a change to selected way point.

Am using the standard keying - FPL then curser to pick new target waypoint then -> to activate direct to or ->/-> to activate leg.

All works fine in the GPS but autopilot, and plane stays on last leg selected. After this I have tried it when doing en-route way point changes with same result.

Have tried  doing a switch to HDG and back to NAV to reset but no joy.

Have also tried various combinations of GPS to autopilot in the settings screen.

Finally tried it in the base C172 to make sure it wasn't a problem with the CIrrus I was in but am getting same result.

Hope we can fix. 

regards

PatrickF

https://www.dropbox.com/s/lnvuabnrffv4z6f/SR20_sequencing.jpg?dl=0

https://www.dropbox.com/s/og65pk9t4zundib/C172_sequencing1.jpg?dl=0

https://www.dropbox.com/s/c350lu7uvnnrgop/C172_sequencing2.jpg?dl=0

 

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

9 hours ago, foges said:

I swung over to P3D some time back but have been frustrated with no realistic 430 to practice IFR. Don't expect to get the 10+ years of use I got out of version 1 but am looking forward to pushing it.

Thank you for your kind words! I'm also glad our products proved to be so valuable over so many years!

As for the sequencing, I'll look into this. Please allow me some time before I come back we news about this, as this most likely related to internal trainer code, although it might also be just A/P coupling related and we are making some adjustment to this part of our add-on right now for the upcoming first update.

This might also be the new WPT sequencing logic implemented in Garmin software 3.3 (compared to software 3.0 of the older trainer).

Please make sure to report any other similar discrepancies you may experience. This will help finding maybe a certain "pattern" or set of circumstances related to this.

 

For information, here are the noticeable changes between software 3.0 and 3.3 of the Gamin GPS code:

 

V3.1:

  • Corrected "Approach Mode" on the Ryan TCAD 9900 and 9900BX to now load airport elevation automatically.
  • Modified behaviour of the Inhibit Terrain user setting; when Terrain is inhibited, it remains inhibited across power cycles (when TAWS is inhibited it does NOT remain inhibited across power cycles).
  • Changed the declutter level settings for Airspace Type; MOA declutter now occurs one level earlier.
  • Changing the waypoint more than once on the VNAV page no longer requires closing and reopening the page.
  • Corrected the operation of the "Ignore CDI key" configuration by suppressing the erroneous message "Select VLOC on CDI for approach".
  • Corrections made to the VNAV operation with Crossfill; there were issues with the selection of a VNAV waypoint on the VNAV page.
  • Improved TAWS availability (GNS 530W TAWS and GPS 500W TAWS) by enhancements made to the performance of the WAAS engine when operating outside of the WAAS service area.

V3.3:

  • Adds the feature of allowing the pilot to manually set the Magnetic Variation in addition to automatic selection. The ability to select automatic magnetic variation is unchanged.
  • The WAAS LP Approach type and annunciation description has been added. An LP approach is flown the same as an LPV approach, except that verti- cal guidance is not provided. Angular scaling is similar to a localizer approach. Most LP approaches have step down altitudes associated with them.
  • The annunciation with a symbol for the CTAF type has been added to the WPT Airport Frequency page.

I've also found out 1 item in Garmin software 4.01 which might be related: "Corrected an issue where TO/FROM toggle for waypoint sequencing did not occur when auto sequencing to a DF leg"

Share this post


Link to post
Share on other sites

Thanks,

I am sure it is AP coupling related in some form.

The response in the GNS is exactly as expected and in each case the new waypoint, or route is highlighted in magenta in the FPL and map on the unit.  It is also sent correctly to the CDI needles, or glass in the Cirrus case  

The updated NAV instruction or flightplan just isn't sent to the plane and the plane continues to follow an old NAV command. It's as if changing in the FPL doesn't initiate a trigger/reset /refresh

Have also noted the issue is the same whether you add waypoints to an existing plan or highlight different ones and use ->  

I'll keep playing and log any other patterns I notice. 

PatrickF

Share this post


Link to post
Share on other sites

Thank you for your astute investigation. I've noticed in the screenshots the leg is to the last wpt in the fpl, and it is an airport? What if there is a wpt after this one?

Share this post


Link to post
Share on other sites

Jean-Luc,

I'll try a few more combinations. As I said GPS working fine - just not commanding aircraft in NAV or GPSS mode when waypoints changed in FPL.

Probably easiest if I do a very short piece of video to illustrate - hard to explain in shots.

Will when I get back to machine.

thx

Share this post


Link to post
Share on other sites

Jean-Luc,

I've done some more testing and am experiencing the issue more broadly. When I am in NAV mode and select a different waypoint using the direct to key the GPS all works fine but as outlined above the autopilot doesn't respond correctly.

It may be isolated to my own set up, although I am running a clean P3D V3 rig and testing on default aircraft so would be surprised if this was the case.

I will wait until I have installed the upcoming update to do more testing and report back.

regards

Share this post


Link to post
Share on other sites

Yes please let me know with the update. Sure enough, in the update thread I've posted info about how it got delayed because of a NAV/GPS bug in the default Baron in P3D4. I just hope this not just related to this, that is regardless of the chi mode, the NAV/GPS switch don't change.

Share this post


Link to post
Share on other sites

Firstly a sincere apology to Jean-Luc and the crew, and a thanks for asking a pretty dumb question - "have you updated P3Dv3 to the latest version?"

I can't believe I didn't update P3D before highlighting the issue. To be fair also can't believe this one slipped through early versions of P3Dv3

There is obviously a difference in how the RXP guys are coding the AP behavior as the competition GNS430 (M....tar) didn't exhibit the behavior  on my set up which is why I never considered it a P3D issue.

Anyway suffice to say it's fixed and all modes I've tested work brilliantly.

Lesson for all. If you are having any issues update your build to latest release, even if it is a bit of a pain as is the case for P3D.

I was avoiding it as I had a nice stable build and didn't want to break it

PatrickF

  • Upvote 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now