Sign in to follow this  
Napalm42

P3D Black Screen on Load - Scenery Issues

Recommended Posts

Hey everyone, longtime lurker turned member here.

I'm having a bit of a common issue which I've tried to troubleshoot. In short, I get the familiar hang up at the splash screen for P3D v3.4 where the splash screen vanishes after scenery loading and simply hangs as a background process. This occurred shortly after installing some add-on scenery for a while, then removing it. I have narrowed down the issue to the scenery loading in particular. If I make a change to the scenery.cfg file (say, turning a bit of scenery off), P3D rebuilds the scenery and then launches without issue as normal. I get no issues for the duration of my flight, regardless of length. If I attempt to close P3D, then load it again without changing scenery.cfg, it hangs.

Here is a list of troubleshooting techniques I have already tried. I am aware that some of them are not directly related to the issue, but with a lack of error feedback I thought covering bases would help.

  • Delete the shaders folder, Prepar3d.cfg, and scenery.cfg from the appdata folders -> no change.
  • reinstall FSUIPC -> no change
  • reinstall all versions of simconnect -> no change
  • checked dll.xml for old addon entries/Carenado entries -> removed old entries, no change
  • updated FSDT's addon manager -> no change
  • checked scenery.cfg for non-existant, old, or redundant entries -> checked and removed, no change.

This scenery.cfg editing is a workable solution, but it's about the same as running on a leaky tire in my opinion. Any insight is appreciated. I'm hesitant to do a full reinstall as I am waiting for more of my addons to reach 4.0 compatibility.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

It could mean a scenery add-on is not properly installed. Are you using LorbySi's Addon Manager to add your scenery or are most of your scenery in the Scenery.cfg (except for the FSDT addons)?  LorbySi has a freeware Addon Manager for P3DV4/3 and AVSIM hosts his support forums here. I have been trying to get one of my Carenado aircraft to work in P3DV4 (the Phenom 300).  I will try to load a FPL and while scrolling up and down or changing a waypoint, P3D will shutdown.  No error msg.  Just shutdown.  I'm almost positive it was my NavData that caused it but think it is more complicated than that.  I get it often but think I now have it fixed.  I have uninstalled/reinstalled the Phenom 300 over 100 times now and ran out of installations for my serial number.  It also happened with my Navigraph Extension.  So have a support request in to increase the number of installs.  The AppCrashView program was giving me a crash report and symmap.dll was mostly the cause.  It also shows that was the cause in the Event Viewer>Custom Views>Administrative Events.  Sometimes the ai_player.dll error would show up.  I'm pretty sure it was the airport I was at - Washington X (KDCA).  If I went to another airport, say, FlightBeam's KIAD, no issues.  Think now it could be a conflict with the airport AFCAD's and Navigraph waypoints.

If you are getting a hangup at the splash screen, then that means you have a problem with one of the dll.xml entries, most likely the CMeteoXml entry if you have any Carenado aircraft installed.  I also noticed the dll.xml was trying to load the 32 bit version of the dill instead of the 64 bit version in the P3D folder - CmeteoXmlx64.dll.  Hopefully Carenado will fix this oversight.  You should also make sure it is loading the 64 bit version of Carenavigraph (if applicable).  The 64 bit version if you have the Navigraph Extension is Carenavigraphx64.dll.  There's also a XMLTools64.dll that should be loading instead of the 32 bit version.  My crashes have stopped since repairing the dll.xml.  The dll.xml is the first thing loaded at startup and all of those modules are loaded.  If one is corrupt or missing, P3D will balk and shutdown.  Sometimes it will let you play then shut you down while you are flying.  It likes doing things like this.

As shown in the AVSIM CTD Guide, you can investigate your situation by following the guidelines in "How to Fix Most CTD's and Freezes in P3D" on page 10 (see link in my signature or the link on the right side of this forum under Hot Spots).  Renaming your dll.xml, scenery.cfg, and p3d.cfg by placing a .old extension at the end of each will allow this files to be rebuilt when you restart P3D.  I return the dll.xml first (there are two of them - one in the same folder as the p3d.cfg and one in the same folder as the scenery.cfg). Delete the rebuilt one and rename the old one back to dll.xml.  Run P3D and see if this fixes the problem.  If so, the issue is in your scenery.cfg or Add-on.cfg.

Best regards,

Jim

 

Share this post


Link to post
Share on other sites

Welp, it seems the culprit was indeed the Cmeteo addon causing a fuss. I had recently installed some Alabeo aircraft and wasn't aware that Carenado and Alabeo were one in the same. I addressed the entry to the correct module and have had no issues after 3 full startups and loads. Thanks for the help!

  • Upvote 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this