Ryan Canepa

Reality XP GTN 750 will not turn on

Recommended Posts

Hello,

I have just purchased and installed the GTN 750 from Reality XP. I am running X-Plane 11. The GTN trainer application installed well and works flawlessly. All of the functions of the GTN work in the trainer application. However, when I try to run the GTN in the default laminar C172 in X-Plane, all I get is a black screen. When I hover the mouse over the GTN, it does show that there are click spots both on the touchscreen, and on the knobs around the edges of the unit. Also, when the GTN is open in the sim, none of the buttons on the default Garmin 530/430's work. I can bring up the 2d popups, but that's it. Every other part of the plane works fine, so I have a feeling that this must be because many of the functions of the GTN are likely linked to the default GPS units. 

Here is what I have tried/checked:

-Battery and Avionics, as well as the engine, are turned on

-Radio/Panel light brightness is turned all the way up

-I switched the GTN to the copilot side

-I have rebooted the sim as well as my PC

-I have looked at as many online forums as I could find that are related to this issue, and tried everything but still nothing.

One thing that I did notice was that during the install, I was never asked for any sort of activation key or anything like that. Perhaps I have missed a step in the installation? I am very eager to get flying with this thing and I hope to resolve this issue soon. The only other thing I can think of trying is to disable the default GPS's, but I am not sure how to do that. I am an aviation enthusiast but I am not the best with computers.

I appreciate any suggestions,

Ryan

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

13 hours ago, RXP said:

Hi Ryan,

You might want to post this to the official Reality XP forum instead:

https://www.avsim.com/forums/forum/767-the-realityxp-support-forum/

At the time he posted the thread, he wouldn't have been able to do so as an anti-spam preventive measure for new members. That being said, he should now be able to do so since the time restriction for new members has elapsed.

  • Upvote 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now