Faelandaea Dravin

NL2000 EHAL Stops Scan

Recommended Posts

Hello.  This is my first post as I have just learned of Simlauncher literally moments ago.

Excitedly I downloaded the latest version, and all seems to go well (once I tell Avast to go "F" itself) but the program seems to lock up during the "Creating P3Dv4 database" on NL2000 v4.0 EHAL every time.  I have attempted this three times now.  It flies through the creation until it hits EHAL, then just freezes up.

The timer on the window is always under a minute when it reaches EHAL ... as I type this it is currently sitting at 8 minutes and still stuck on that airport :(

Is there a way to force the program past this without uninstalling EHAL?  I am looking so forward to using this program as a moving map for my stream next week, so hoping to get past this by then.

Thanks in advance :)

 

EDIT:  Attaching the following video to assist and show better the issue I am having.

EDIT 2:  Major omission on my part ... i forgot my PC specs.  Sorry.

  • The system is Windows 10, with Admin Privileges and, of course, UAC gutted from the system.
  • Intel Core i7 3.33 GHz Black Edition overclocked to 4 GHz
  • Asus ROG 1080 Strix graphics card
  • 64 GB Gskill Ripjaws memory

Also, I have assured that SimLauncherX is set to run as Administrator.  With the program still open and hanging at EHAL, there are no errors in the log.  The final line in the log is currently:

20170922202919    Processing scenery layer: Area.195, NL2000 v4.0 EHAL

No errors or lines after that.

If you need more specific specs, let me know, but those are the important specs related to processing and performance which would most likely be a factor in an issue such as this.

Again, thanks.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi Faelandaea,

I will go and install NL2000 myself and see if I can reproduce the issue. In the mean time you can temporarily disable the NL2000 scenery layers in the scenery.cfg file by setting the active= key for these layers to False. After the database has been created, you can activate the layers again.

thanks, Maarten

Share this post


Link to post
Share on other sites

Hi Faelandaea,

I just installed NL2000 myself and I have no problem whatsoever creating a new database with all packages installed. It could be that one of your.bgl files for that package is corrupt. Please uninstall the EHAL (Ameland) package, download the package again from the NL2000 website and reinstall.

thanks, Maarten

Share this post


Link to post
Share on other sites

Hmmm.  I guess I have to uninstall EHAL then, because for me EHAL will not scan.  As you stated, may be a corrupt file.  I am also wondering if the fact that I am using the NavData from https://www.aero.sors.fr/navaids3.html might be an issue as well?  But if that's the case, not sure why it would stop at only that one airport.

I'll try reinstalling EHAL after work tonight and see if that resolves the issue.  Thanks for the assist.

Share this post


Link to post
Share on other sites

I tend to agree.  Definitely.  I just wanted to mention it because when i report an issue to a developer I try to include as much detail as possible, even what may not be obviously related.

Well, I uninstalled EHAL completely, then downloaded the latest installer from NL2000 (I was running 4.0.78 ... now I am running 4.0.79).  I then re-downloaded EHAL from scratch as well and then used the new installer to reinstall it.  Same issue.  So I uninstalled EHAL and just left it out.  Now the program is freaking out on area 170 EHBD.  I do not know what the heck is so different about my setup from yours, but this program just really seems to hate the individual airports from NL2000.

Uninstalled EHBD, tried again, froze on area 169 EHBK.  ~facepalm~  And looking at my screen I actually saw that one coming.

Strangely enough it seems to be freezing on whatever airport is at the top of my list in the NL2000 installer with the exception of EHAM.  it seems to like EHAM.  But it hates the other airports.  Looks like if I am going to be flying the Netherlands, I cannot use this software on my setup.

Fortunately, right now most of my flying is in the USA, so I am considering just uninstalling all of the NL2000 scenery completely and hope that in the future I can try again.

And, to confirm, no there are NO errors at all in the log file for SimLauncherX. It just stops on that line at the airport it is trying to process.

Share this post


Link to post
Share on other sites

UPDATE:  I have one by one eliminated all airports and scenery from NL2000. The program froze on every one of them except for EHAM.  It also froze on every one of the photo-scenery, libraries, and buildings/autogen.I had to uninstall all other NL2000 scenery.  Again, whatever is different on your setup, this software hates NL2000 entirely for me.

I have also uninstalled EHAM because without the libraries (which it also froze up on) EHAM would not function properly anyway.  Once I uninstalled all NL2000 sceneries, I was able to create the database and start trying out this software.

Just to clarify, i am currently using version 6.0.6473.2647  of SimLauncherX.  That is the version I am supposed to be on currently, right?

Share this post


Link to post
Share on other sites

Hi,

It sounds like there's an issue accessing files in the folder where you have installed NL2000. I will send you a PM with a link to a test version that includes some extra logging and safeguards against file access errors.

Maarten

Share this post


Link to post
Share on other sites

I will be happy to try that out and assist to see what we can find out.  I know if i am encountering the issue, others may as well in the future.  I do have NL2000 on its own hard drive, but it is in a custom directory (that is actually crucial because Windows likes to take anything titled "Programs" or "Programs (x86) and lock them down ... so I avoid those folders like the plague).

On the good news front, once I uninstalled UK2000 and got this software started, it looks really cool.  I have yet to boot the sim and try the moving map feature, which is actually my PRIMARY reason for my interest in this software, but the interface looks cool so far and the map looks awesome.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now