Mejjo

Alabeao 300s Pulls sharply to the left?

Recommended Posts

Hi all,

So i've decided to fly a few of the default aircraft that come with P3D. I'm just wondering if its me that has a problem here or if this is normal. When i start on the runway with the Alabeo Extra 300s and apply full thrust for takeoff, Within seconds the aircraft pulls sharply to the left. I apply rudder to make the correction but the plane just spins out of control and doesn't seem flyable. Is this normal for this aircraft to do this? 

I'm not sure if i'm doing something wrong. I have made sure that my joystick is calibrated. 

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Hi Michael,

It's most definitely flyable - seemed the FDE was pretty well done IIRC... I don't know your experience - but - most prop planes pull to the left and require constant right rudder on takeoff - there are a number of forces at play... Now strap on a complete beast of Lycoming 540 (300 HP) engine on a light little plane and those forces are magnified exponentially... You can compensate by setting the rudder trim (don't recall if model has it) and/or gradually increasing power and/or not using full power on takeoff... This isn't a weekend cruiser - this is a barely contained monster on steroids... Again - I did mess with this a bunch - although it's been a while - and it seemed well done and completely flyable albeit not really meant for a novice...

Regards,

Scott

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now