himmelhorse

FS2004 saitek controls assignments not saved

Recommended Posts

Hello all,

In another post I was having problems with not being able to launch FS2004.

That problem has been resolved but only with a full format and re-install of Windows 10 (with all the peripherals) and then a reformat and re-install of FS2004. This has worked beautifully and I am very happy except for one small thing.

Every time I start a flight or change aircraft, I now have to reconfigure all my controls. None of the buttons/keys assignments or the Axis assignments are being saved.

I have actually seen a thread on this, but do you think I can find the bloody thing. Googling simply gets FSX responses which to me are as useful as udders on a boar pig. They address the subject but I believe that there is a huge difference in the way that that is handled.

I went into my fs9 config and found: 

[CONTROLS]
KBDAIL=64
KBDELEV=64
KBDRUD=64
PAN_RATE=100

In the FSX topics they are talking about a html add on to this part of the config.

Am I missing that part ... should there be more to this part of the config (controls) and if so what is it?

Am I even looking at the right place?

I am pretty sure (I think lol) That these settings cannot be saved in a separate folder for use with a later install and every install requires these control axis and button assignments need to be redone with every install. IF, this is incorrect, can someone tell me how to save it please.

As an aside.... When I am setting up key/button assignments. I always delete all, and I mean all, button/key assignments that I do not use (ie Multi player, comms, nav, helicopter controls and tail dragger controls etc. This is done with the initial Yoke set up and done first. Staying with the yoke I then set the assignments that I want to use. (not many because I generally have all my instruments panels displayed (ie Boeing 737/747) and just click on the buttons or knobs)

I generally start with the Yoke/quadrant  and then move to trim wheel, second quadrant and then rudder pedals. The really strange thing is that after I set the yoke, I then find that the trim wheel has allocated non-existent buttons for things like landing gear up and down, panning, recycling views etc (about 6 in total) So I delete all the controller assignments in the trim wheel and move to the second quadrant where I find exactly the same assignments. I delete all of them and move to the Rudder pedals and find them there too. So I delete them and then move on to the Axis assignments. Changing the order of precedence has no effect whatsoever, ie yoke, rudder, quadrant or trim. This has been happening since my original purchase of the FS2004 cds. It happens with the DVD version I have and it happens with the USB version (all purchased or obtained at different times)  I have never really worried about it but if that can be solved at the same time it would be a bonus.

I am really looking forward to a solution with this one.

Regards to all

Tony

 

 

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hello all,

Problem sorted out now and all running well

Thanks for any intended assistance.

Cheers

Tony 

Share this post


Link to post
Share on other sites

Hello again,

I just re-read that last, and it sounds very abrupt. It was not meant to be. 

However if anyone is wondering this is related to my other post "fs2004 install problems" which I started recently.

The full explanation to the resolution of this problem is outlined in that thread.

So again, apologies if this was taken to be a little abrupt.

Cheers

Tony

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now