Rob Ainscough

P3D V4.x version checking?

Recommended Posts

Do the RXP versions of the 530/430/750/650 look for a specific version of P3D V4.x and will NOT work if it finds a version not officially listed?  (similar to how the GTN/GNS work from F1)

Cheers, Rob.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

That didn’t answer my question, perhaps I should clarify.  

Some products look for a specific version I.e. 4.x.y.z and if they don’t find that version they don’t work and/or provide a warning.

Some products do this to manage support, others have a specific offset/link they need in order to function correctly (I.e outside the SDK/PDK).  

Those in the later group is where my question is aimed at as that requires updates to be released every time a P3D hot fix or minor version update is released.  I’m trying to determine if this is the case for RXP products?

If not the case, this would be an advantage for me as I would 750/650/530 etc. functionality for minor P3D version updates and would not have to wait for the vendor to provide and update (which is how it currently stands for F1 series).

Cheers, Rob

Share this post


Link to post
Share on other sites

Hi Rob,

Both the GTN and GNS V2 are not dependant on P3D4 updates (unless they change a lot one day in the 4.x series), except for the autopilot coupling. This means you can still use the GTN and the GNS V2 for navigating, flight planning etc... until we release the update with the P3D4 A/P coupling specific code.

We've been working in making this sole part of our products self-adapting but have not been able to put more work on this yet. Our goal is to have it self-adapt to each new P3D4 updates so that it lessen our support too!

Share this post


Link to post
Share on other sites

Hi Jean-Luc,

Thanks for the response.  So the A/P will not work until coupling code is updated, but I will still get all other functionality.  Hope you can workout the self-adapting as that would be a huge benefit for me and my testing.  I was able to get the 530V2 working in my version of P3D V4.x in the Carenado PA42, but have not tried A/P yet and sounds like I should not expect it to work. 

On unrelated topic, the Garmin GTN/GNS Trainer software -- I have the F1 version installed and installed your version into a different folder ...this seems to be working but it did confuse the RXP installer (it never finished).  For those of us with both F1 and RXP what is the recommendation for installation of the Garmin Trainer software?

Cheers, Rob

Share this post


Link to post
Share on other sites
2 minutes ago, Rob Ainscough said:

For those of us with both F1 and RXP what is the recommendation for installation of the Garmin Trainer software?

 

A recommandation ? stop using F1 product, RXP one is better in all aspects (i own all products, GTN and GNS from F1 and RXP)

  • Upvote 2

Share this post


Link to post
Share on other sites
7 minutes ago, Rob Ainscough said:

but have not tried A/P yet and sounds like I should not expect it to work.

Both the GNS V2 and the GTN are compatible with P3D4.1 as well as: P3D4, P3D3, P3D2, P3D1, FSX-SE, FSX-ACC, FSX-SP2, FS9

This includes the A/P working with P3D4.1 too!

9 minutes ago, Rob Ainscough said:

this seems to be working but it did confuse the RXP installer (it never finished) ... what is the recommendation for installation of the Garmin Trainer software?

The Reality XP GTN 750/650 Touch supports Garmin GTN trainer 6.41, 6.21, 6.11 (also 6.01 and 5.0 but disabled in the latest builds, we will only keep the last 3 trainers versions in our releases).

Trainer 6.41 installs in different paths than the previous trainers, it also installs alongside the others.

Our GTN simulation add-on auto-detects the most recent version installed, and picks this one up. However, you may also manually override the auto-detection and selectively redirect: the entire path to the trainer, the path to the trainer data files, the path to the trainer navdata. It is documented in the User's Manual and this uses environment variables.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now