mikealpha

Device assignment and calibration

7 posts in this topic

After having seen drivers for my 737 Opencockpits modules available, I decided to give XPlane and the IXEG 737 a try. Looks great so far, just the device calibration gives me a headache.

I have several devices : TM 16000 stick, a Brunner FFB, which is calibrated outside XPlane and connects via PlugIn , a 737 Throttle replica for Jets, CH Throttle for Props and using the buttons for changing views. Pedals and a 737 Steering Tiller Replica. I have assigned them all, using Ignore Axis when appropriate.

1. Xplane keeps telling me I have multiple Yaw axis defined, consequently there is no yaw movement in the sim. I checked it several times, there is only one yaw axis defined with my pedals. Is this a bug ?

2. Everything is sooo sensitive. There is some influence for the slope of elevator, aileron and yaw, but not for the other axes. If I use approx 10% of my tiller travel, it literally throws the plane around. Is there any general sensitivity setting somewhere in the ini files letting me reduce sensitivity by at least the half ? Or any other workaround ?

Any insight would be much appreciated.

 

Mike

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

1. Try opening the "X-Plane 11\Output\preferences\X-Plane Joystick Settings.prf" file, and search for all the entries named "_joy_AXIS_use". The yaw axis assignment should be identified by the number 3 (after the space), so check if there's more than one axis followed by the number 3, e.g.:

"_joy_AXIS_use4 3"

...

"_joy_AXIS_use9 3"

Make sure there's only one axis assigned to yaw (3).

 

2. In the same file, search for the entries named "_joy_prat". They represent the sensitivity of each control axis. First of all, you have to identify the axis you're interested in, and then you can increase the relevant number to decrease its sensitivity, e.g. say you want to modify the sensitivity of axis 6, you would edit from:

"_joy_prat6 0.000000"

to:

"_joy_prat6 1.000000".

In theory, 1.000000 is the max value (least sensitive), I don't know if you can use even bigger values to have even less sensitivity, but it's probable that in this case the value would get reset to 1.000000 everytime you enter the control settings screen.

 

Share this post


Link to post
Share on other sites
7 hours ago, Murmur said:

1. Try opening the "X-Plane 11\Output\preferences\X-Plane Joystick Settings.prf" file

thanks a bunch ! That has helped to identify the wrong second yaw axis, no idea how it got in there. Yaw is working now. !

Also thanks for the info regarding sensitivity. With that many axes it will keep me busy for a while fo figure out which is which just with numbers :-).

Mike

Share this post


Link to post
Share on other sites
1 hour ago, mikealpha said:

thanks a bunch ! That has helped to identify the wrong second yaw axis, no idea how it got in there. Yaw is working now. !

Also thanks for the info regarding sensitivity. With that many axes it will keep me busy for a while fo figure out which is which just with numbers :-).

Mike

Well, you could temporarily assign a known function (e.g. yaw = 3) to the axis you're interested to identify, then open the joystick settings file and check what axis id has now the number 3 assigned to it (e.g. _joy_AXIS_use11 3"), so you know the axis id (11 in my example).

 

Share this post


Link to post
Share on other sites
17 hours ago, Murmur said:

Well, you could temporarily assign a known function (e.g. yaw = 3) to the axis you're interested to identify, then open the joystick settings file and check what axis id has now the number 3 assigned to it (e.g. _joy_AXIS_use11 3"), so you know the axis id (11 in my example).

 

Thanks again, very good idea, will do this way !

Mike

Share this post


Link to post
Share on other sites

sorry if I'm butting in where I din't belong but- Ican't reduce sensitivity of my Logitech Extreme 3D PRO.

I don't get any prf files . there are only "pics rules file  ""

 

Share this post


Link to post
Share on other sites
2 hours ago, mitchb said:

sorry if I'm butting in where I din't belong but- Ican't reduce sensitivity of my Logitech Extreme 3D PRO.

I don't get any prf files . there are only "pics rules file  ""

 

Those are the .prf files. Click with the right mouse button and choose "Open with...", then use notepad or wordpad or any other text editor.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now